Rock Pi flooding router when connected via ethernet?

Hi, I have problem with other devices that are connected to the router via ethernet, when there is already connected Rock Pi.
Each device randomly loses packets or whole internet connection, even wifi one.
Unplugging Rock Pi from router immediately fixing all problems.

Also there is nothing that can drastically consume bandwidth on the Rock Pi, only SSH and 0 connected devices to it.

Rock Pi connection working fine, RockPi <-> router and RockPi <-> router <-> internet

I can replace Rock Pi with other device (Win or Linux) and other devices also works fine.

There is no QoS on the router.

Has anyone faced similar problem?

Is your ubuntu server running dhcp?

Yes, this is base Ubuntu server from Radxa and there is some kind of dhcp daemon running in the background.

Client or Server, DHCP client is fine but maybe you have an extra unwanted server one running?
What ip do you clients fetch when they lose connection, still doesn’t explain packet drop however.

I haven’t really noticed the same and have you done the usual updates?

apt-get -y update
apt-get -y upgrade
apt-get -y dist-upgrade
apt-get install -y rockchip-fstab
apt-get install -y rockpi4-dtbo
apt-get install -y rockchip-overlay
apt-get install -y linux-base
apt-get install -y linux-4.4-latest
apt-get install -y rockpi4b-rk-u-boot-latest
apt-get install -y bluez ap6256-firmware
apt-get install -y brcm-patchram-plus1-64

Also in Bionic networking is now netplan and not configured via /etc/network

Client - /sbin/dhclient -d -q -sf /usr/lib/NetworkManager/nm-dhcp-helper -pf /run/[...]

Some of this was already installed but I’ll check how it will behave now after installing all of this.

Nothing changed, same problem.

Dunno as long as you setup your network via netplan kept the new bionic networking system on mine I don’t seem to have the same problem.
Or at least never noticed it.

Guess your going to have to track through syslog and see if there is anything that gives you a clue.

Prob going to have to install some network monitoring tools like iftop and see if you can gleam any info.
Not heard anyone else have similar so out in the cold and blind to whatever it may be.

Few people reported a similar problem with Raspberry Pi, unfortunately without clear solution.
Some pointed out voltages or IP address conflicts.

Problem appears about 10 minutes after turning on Rock Pi. But there is nothing in syslog that indicates network problems.

OT: Is it possible to run Alpine on Rock Pi?

Never used Alpine its an Arch Linux base?
Only thing currently is the mangaro that is near

Ethernet is working but with manjaro sticking to mainline only WiFi/Bt will be 5.3.

Then there is the debian image, but try the KDE I know its desktop but if its hardware specific then likely it should turn up again.

No, it’s based on busybox and musl library, great for low resource usage that’s why it’s mainly used as Docker base image.

Yeah, probably going to try different distro. :frowning:

The docker images should still work but hardware wise with a different kernel the arch based mangaro of the above is really it.
Also even though its a game emulator the networking with likely different kernel setups is in the (mrfixit2001 has backported loads of patches) recalbox and libreelec images which is pointless for what you want but will test hardware.
Then there is debian without netplan and standard /etc/network if you get rid of desktop or use the build script as its quite easy.

What’s the best choice? Debian from official wiki ( or this one .

The download is full of desktop gubins and the forum version is just community supplied. is seriously easy just remember to export the Arch you require.

I will build one if you want and run through the networking as haven’t paid debian all that much attention.

My machine is multiboot win10/stretch/bionic with an i7 with an OK OC and it rips through that build script in no time.
You end up with a really basic Debian which is perfect for building up a server which I could prob do for you.
I use option2 rather than docker but if your a docker person that may suit.

1 Like

If you can build it for me I’ll be very thankful also thanks for your time. :slight_smile:

You can time me as stuff is already in the oven and I have nothing else better to do :slight_smile:

I don’t think that went all that well as build the desktop before but when I set target=base I am pretty sure from what I am seeing that is desktop.
Anyway uploading to onedrive.
I tried a couple of times thinking must of missed ‘base’ but we will see which it is :slight_smile:

Ok, that’s not a problem even if it ends up with desktop :slight_smile:

Nope I tell a lie its not desktop but it pulled in far more packages than what I would call say ubuntu-minimal.

Its just my broadband and uploading aint the quickest its just called system.img
user linaro
password linaro!AocmAh35i26QiFH4K-KC0pBeIAEE

linaro@linaro-alip:~$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group defaul                           t qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP gr                           oup default qlen 1000
    link/ether 5e:17:09:fa:85:de brd ff:ff:ff:ff:ff:ff
    inet brd scope global dynamic eth0
       valid_lft 84458sec preferred_lft 84458sec
    inet6 fdd4:40f0:f40b:b400:d47c:7c2d:ea3:6886/64 scope global noprefixroute d                           ynamic
       valid_lft 6896sec preferred_lft 3296sec
    inet6 fe80::a3c4:eb24:1bd5:b6ea/64 scope link
       valid_lft forever preferred_lft forever
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast                            state DORMANT group default qlen 1000
    link/ether 6c:21:a2:14:d8:c8 brd ff:ff:ff:ff:ff:ff

I am in the UK
dpkg-reconfigure locales
to where u are

PS I keep forgetting about Armbian and they have great images even though I also keep forgetting to try!

Damn… same problem, even faster this time, 2 min after boot.
I’m starting to think that the problem is more on the router side but still, caused by Rock Pi.
IP was assigned correctly and there is completely 0 traffic from Rock Pi.