Rock Pi E Slarm64 (aarch64 unofficial slackware)

installation README.TXT
kernel 5.19.0

slarm64-current-aarch64-server-rock_pi_e-5.19.0-build-20220805.img.zst
slarm64-current-aarch64-server-rock_pi_e-5.19.0-build-20220805.img.zst.sha256

installation README.TXT
kernel 5.19.12

slarm64-current-aarch64-server-rock_pi_e-5.19.12-build-20220930.img.zst
slarm64-current-aarch64-server-rock_pi_e-5.19.12-build-20220930.img.zst.sha256

installation README.TXT
kernel 6.0.0

slarm64-current-aarch64-server-rock_pi_e-6.0.0-build-20221010.img.zst
slarm64-current-aarch64-server-rock_pi_e-6.0.0-build-20221010.img.zst.sha256

Hi mara, I would like to ask a few (dumb) questions, if I may. I have been running slarm64 server on a Rock PI E for quite a while now. I use it as my router/server. (You may recall that it was after my post asking about more functionality that you started creating a ‘server’ instead of a ‘base’ version). So, finally I bought an eMMC module and transfered my system with the ‘transfer-to-disk’ command. After a reboot, it was going fine, except the date was set to 2029, and would not reset. rc.ntpd was running but the connection was constantly rejected, and would not correct the date. So I disabled it, and the only way I could maintain correct time is to run ntpdate -u us.pool.ntp.org as a cron job every 5 minutes, otherwise the date would reset to 2029 again and again. Does this board have a harware clokc? If it does, it is not being recognised, hwclock command times out waiting for /dev/rtc0. Does my problem ring a bell with a solution? If not, that’s ok. Thanks for this slackware, I love it, and serves me well.

Cheers,
Karl

There is no default hardware clock on this board. I have a script /etc/cron.d/fakehwclock that updates the date in cron, try deleting it and restarting cron.

That fixed it!
Thank you mara!