Rock Pi 4C NVME booting!

I just wanted to verify something about the 4C. After loading the correct Debian OS (for the 4C) on SD boot media I ran the update and upgrade commands in the LX Terminal.

I noticed the blue light on the board was blinking before the update so on a hunch I installed the Acer NVME SSD 128GB I purchased from Allnet.

After the update and upgrade I noticed what looked like the SPI bootloader code updating. To my surprise I’m now able to boot from and run on the NVME SSD only!

So my question is whether I’m correct in the assumption that the SPI chip did indeed get the bootloader installed as a result of the update and upgrade?

Thanks!

Thanks

When you said “I ran the update and upgrade commands”… do you simply mean sudo apt-get update, sudo apt-get upgrade?

If so, I think it takes more than that. I just got a brand new 4C and have also loaded Debian onto both an eMMC and an NVME SSD and after doing apt-get update /upgrade it doesn’t even attempt to boot from the NVME without the eMMC.

-Jim