Rock Pi 4c mDP no video

Just got my new Rock Pi 4c but I’m having trouble getting anything on my monitor. I tried practically all the images available but only the Debian Desktop 9 image is booting up correcty.
I’m using the mDP output with a Dell 4k monitor. I think it’s a DP input in the monitor as well.

Any ideas?


Yes, me too here has the same symptom, as a fairly computer illiterate just wondering what’s wrong with this, it came straight from ALLNET’s warehouse few days ago.
RockPi 4 c ver1.2, yes its version is 1.2 although it was posted just couple of weeks ago, and an SPI chip seems to be soldered onto it. It can create /dev/mtd … when it happens to boot, and visibly shows debian desktop through DP.
The one and only OS-image which boots so that mDP gives out “regular” desktop images is rockpi4c_debian_stretch_desktop_arm64_20200716_0647-gpt.img, (in fact the screen is very bright, sharp, and good with this)
Other options rockpi4c…ubuntus, debians,xfce, ARMBIANs.img give out nothing, so nothing on the screen, no nothing, all dead from both tv-outputs. But apparently based on those green & blue blinking leds it’s doing something while switched on. So if some guru has faced this before and could guide a bit if it happens to be just some simple setting eg. in /boot/env tty…? etc. file, and as said this one here is not a computer wizard plugging in TTL-wires doing this & that analysis, out of my understanding, far off.
As a comparison I happened to buy an Orange pi 4 which woke up immediately with Armbian’s os image, and been booting and working well from its emmc-chip, but Rockpi 4c ver 1.2 dislikes 3rd party OSes alot, apparently, and even in-house devels not working that well either.
So, the question- Any ideas- remains.
Br Vesa

For me it worked copying the dptx.bin file from /lib/firmware/rockchip/ in a debian9 version to the same location in the debian10. Its the driver for the mDP.

Hi, Thanks a lot for answering so quickly. In my case this did not help, so still having only one working sd-card. What I did was just copying dptx.bin from a working sd-card, cp /…/dptx.bin /…/rockchip/dptx.bin, and regular mkdir if the folder not present. Remembering something from Linuxes just copying modules from kernelXX to kernelYY usually does not work very well, so guessing that kernel versions are not matching here now.

And one curiosity here is that none of the sd-os-images gives anything to its hdmi-port, not even the one with the working DP. So out of 4 sd-cards having os-images meant for rockpi4c, only one is working somehow.
br vesa

Oh, understood, I`m facing this kind of issue with multiple versions of os images, only 2 of them worked (debia9 dual display and… I’m far for my rock pi at the moment I’ll give details of which ones worked) same problems with multiple os images to get de mic of headphone jack working as well.

Why don’t you simply use the microHDMI video output on your RockPi4C with a microHDMI to HDMI 4K cable connected to your Dell 4K monitor?. It’s easier to configure and works out-of-the-box with most OS’s.

I also have the problem that I can’t get the DP connection to work on the current Armbian images.
HDMI works absolutely perfectly but there is zero, nothing, nada on the DP connection. The monitor only reports no signal.
I wanted to use this because my monitors were already using their HDMI ports and I wanted to bypass the switch.
But the RockPi4C doesn’t seem to like my 4k BenQ EW3270U in general, it only works correctly after the manual setting, the automatic detection causes problems on the RockPi 4 B&C and the Raspberry Pi 4.

Thanks for your answers!
The reason, I tried mDP is that that´s the cable I have.
Thanks for pointing out that hdmi seems to be without problems.

I also noticed and I have 3 RockPi4C’s have been dealing with that microHDMI output on RockPi4C can be picky with certain microHDMI to HDMI cables. I had 2 Rpi4 8Gb which use similar microHDMI video out, I pulled those working cables and didn’t work on any of my 4C’s. I had to buy new 4K cables(amazon brand) and problem solved. Cables on Rpi4’s weren’t 4K, so go and figure. My main monitors are 4K TV’s running always at 1080p.

Yep, in ver1.2 the only working os seemed to be hereabout:
both dp and hdmi work, although dp without sound, speakers in the display, 32 inch AOL, 1920x1080 works well
Bluetooth yes, wlan yes,
SD cards with the above mentioned os 32GB PNY and 32GB SANDISK,
and no armbian neither any other os wakes up the display :frowning:
The next step is to get it booting from spi, already got it to read its os from an nvme but not without an sd-card, /dev/mtd* disappear when the nvme hd connected.

Okay, a little update, after some desperate moments:
Now it seems that nearly whatever SD I feed into this 4C v1.2 it can accept. It can boot Armbians and inhouse rockpi4c_ .img. To get HDMI working I had to change the cable, from a quality tm HAMA to Aliexpress No-Name…
Nvme works now with Armbian 21.02.1 Buster, and after rigorous trial-error-cli playing it eventually became bootable just with Armbian’s own config-tool. How this exactly happened I’ve no records, a lot of trial-error efforts to get the SPI chip waking up… Anyhow now it boots from Samsung 970 Evo Plus 500GB. and the next step is to get some understanding how the hd partitions should be arranged. There are nvme0n1p1…5, and no idea where it keeps the working os or boots from as there seem to be earlier randomly dd-ed “ghost” systems present.
So shortly; hd booting works without sd-cards (note ver 1.2!), HDMI works with a new cable and all sd-booted, and DP does not work with any Armbian. DP seemed to work only with rockpi’s os versions.

To have a hd-booting system with dual display - no, for now.

I use the Armbian Focal Desktop
And everything works properly, except for the mDP.
Since this works with the Radxa image, it cannot be my cable or monitor. I think it’s a shame that I can’t get it to work. But luckily, I don’t need it.
After you have just got the system to boot from the NVMe, you should be able to simply reinstall the latest armbian, first delete all partitions and create a single FAT32. Then boot from SD or eMMC and later use armbian-config to push everything onto the NVMe.
If that doesn’t work, follow these instructions:

But then you only need the part from 6. Run nand-sata-install

1 Like

Right, to be more precise the working mDP was with this but no sound out of the display’s loudspeakers. Radxa’s instructions for nvme booting were cryptic enough and, in spite of spending hours with them, I could not get it working I started playing with Armbian, which was more like a plug-n-play, and now working well. As it now boots and somewhat works I keep my fingers off the filesystems by experience. I’ve messed up folders, mount points, volumes, (non?) logical volumes, kernel upgrades etc. resulting in completely non-booting systems, so I’m a bit lost with these although been using Linux Debians for some years. It’s the learning curve :slight_smile: , and main interests somewhere else…

Okay, like you guys I have been messing with this. I am pretty sure at this point it takes a few pieces to make this work that haven’t been documented – at least that I can find. Those would include:

  • Changes to uboot (recompile) to have it initialize mDP port (no documentation on how to build for your self that I can find)
  • Update to DTB to match one used in Raxda image
  • Linux DP display driver being included in kernel
  • Firmware file as mentioned in previous comment

It would appear that someone took their time putting together the images
rockpi4c_debian_stretch_desktop_arm64_20200716_0647-gpt.img.gz and Android 10 to include these tweaks so mDP works, but didn’t document it anywhere so that it can be replicated into newer images. I know that Armbian has a few people, including my self trying to get it working, though, so hopefully something available on that front here soon.

It is CNY now so I am sure official responses will be slow, though hopefully after the holidays if Armbian hasn’t figured this out we can convince someone over there at Raxda to give us a hand.

To note, I have had mixed success with mini-dp adapters. I have had the most success with mini-DP to VGA adapters while I have so far tested 1 mini-DP to HDMI that has “worked” but flickered on and off constantly. I have another adapter on the way to test as well. Of course, this is only with the Raxda provided image for Debian / Android where it has worked at all.

If anyone is interested in the adapters I have tested specifically, reply and let me know and I can provide them / links.

my 2 cents.


The mainline kernel does’t have the standalone DP driver for rk3399 yet. Our friend Jagan submitted the patches some time ago using the virtual USB PD driver, which is how Rockchip 4.4 kernel implemented. This series of patches can work but it will not be merged upstream.

Apply these patches to the Armbian kernel, we will have mDP working.

1 Like

@jack Thank You!

Now I have something which I can poke at the Armbian team with and see if we can get something working there. I am personally excited to see this working on the Armbian Legacy image with the full acceleration framework now available there – – This may actually result in a fully working image for the RockPi 4c as a Multi-monitor desktop that will be both stable and be able to handle VPU accel – finally something to possibly unseat the RPi 4 as a reliable, accelerated, multi-monitor thin-client.


Actually, after looking at this more I think I may see what you were saying. Will attempt to patch kernel and use Armbian legacy uboot and see if it comes up. Will update again if we see issues.

Thanks again.


It would be really great if this worked on an Armbian Focal Desktop with a 5.10.Y kernel.

First of all I’ve to say that I admire a lot your precious work with these tiny matchbox sized wonders. I fell in love with these for their compact size. So much bookshelf room saved for some other use, and not reserved for a big tin box. Further, their capacity is well enough for my everyday use, so in this sense these are excellent gadgets. I have both an Orange Pi 4 and a Rock Pi 4c, and I’ve started my “research” with an Rasp Pi 3B, which I got bricked/fried after shorting accidentally some forbidden gpio pins…
Now, it seems that my stumbling with my Rock Pi 4c v1.2 goes on. Namely, its hdmi signal faded away yesterday, and whatever cable (with hdmi-hdmi + adapter, or hdmi - mini_hdmi ) I try on does not work. Even the same cable which works on my Orange Pi 4 does not work on the Rock Pi 4C v1.2. What I’m now guessing is that that the mini-hdmi-connector on the pcb is not well soldered or the connector has permanently given up, which is quite unfortunate as I’ve already got it booting from its 500GB nvme and as such it was pretty good for me. It was about to replace an old Debian Desktop AMD A10-5800K, mainly for its size and silence. But now as there’s nothing on the screen, no much use of it. But but… its miniDP is so much sturdier mechanically than the tiny hdmi connector, if there were means to get the dp-connector working…
And yes, now I’ve a working UART-cable showing that my Rock pi 4c boots ok, command line works, and so forth, but to use it “alone” in a graphical environment without any other means does not work. I’m pretty sure it’s a questing of either the m.hdmi-connector or soldering quality as it earlier needed some position adjustments of the hdmi cable & the connector to get it working.
So, the next step, some flux & a soldering iron perhaps…

ps. this from my Orange PI 4 :slight_smile:

The guys in Armbian have been continuing to work on this, we managed to get eDP and DP via USB-C on some of the other rk3399 boards and we do have a DTB / kernel where things are almost work in mainline for mini-DP, though still hitting some obstacles for it to load and work as it should. I feel like we are close though.

Will try to continue to give updates as we make more progress.

@jack if you do have any other resources you would like to pass on, please do :slight_smile:

@jack can you also make it so I can post more replies here?!?!


1 Like