Rock Pi 4B with PoE hat won't boot without HDMI monitor

Hi all,

I got a Rock Pi 4B v1.4 with the official PoE hat v1.2. I don’t know if I have a damaged hat, or if it is some kind of bug, but I have a problem booting. When I plug in the Ethernet cable, the green power LED is blinking for about 15 seconds before it turns steady and the blue status LED starts blinking. After that everything looks fine.

But that is only if the HDMI cable is plugged in. Without it, the green LED keeps blinking on and on and on… The system never boots…

I am using the official Debian Stretch image from Radxa with kernel 4.4.x, booting from 32GB eMMC. Trying the same image from 32GB SDHC uSD is showing the same result. I followed the guide from the wiki and installed all needed packages for the PWM fan control and the rock-poe service as well. All software is up-to-date, updated via apt-get.

I don’t know if it is relevant, but I had a few solder joints on the PoE hat that I needed to fix because they apparently didn’t take and QC missed it - two of the electrolytic capacitors were just flapping in the breeze…

Any ideas?

When I plug in the Ethernet cable, the green power LED is blinking for about 15 seconds before it turns steady and the blue status LED starts blinking

This is not normal, the green LED is for power, which means the power is not stable at the beginning. What the model of the PoE switch?

I had a few solder joints on the PoE hat that I needed to fix because they apparently didn’t take and QC missed it - two of the electrolytic capacitors were just flapping in the breeze…

I don’t quite understand this. Can you take a picture? You mean you manually soldered some capacitors?

Hello jack,

The switch is Ubiquiti UniFi 8 60W (US-8-60W), which has 4x auto-sensing 802.3af PoE ports. Currently only 2 devices are plugged in - the Ubiquiti nanoHD wifi access point and the Rock Pi 4B PoE hat. It should have more than enough power. I also tried the Ethernet cable in each of the PoE ports on the switch just as a test, with same result. Lastly, I also tried a separate inline PoE power supply, same behavior.

Yes, exactly. The 2 10uF electrolytics in the picture did not have any solder on their ground pins and were just hanging by the other one (noticed it when I turned the hat upside down to plug it in). I don’t know know if the machine ran out of solder paste, or if the stencil was dirty; in the end it doesn’t matter. I looked at the whole board under my microscope, both sides, but didn’t notice any other cold joints.

Looking forward to your answer.

I just received a second set of Rock Pi 4b and PoE hat, bought from the Allnet store. The behavior is exactly the same. No boot without HDMI monitor. Why is having a monitor connected a requirement? This makes no sense…

I believe 802.3af is not enough for ROCK Pi 4.

Can you try the Ubuntu Server? It consumes less power.

I did several more tests, as follows:

  • Connect PoE Ethernet cable only. Nothing else is connected. For both Rock Pi 4b with PoE hat the green light blinks on and off, nothing else happens. Waited for several minutes, then interrupted the test.

  • Connect PoE Ethernet cable first, then add USB-C power cable. No monitor. The green power light turns steady, but the blue activity LED never turns on. If it were a question of enough power, both USB-C and PoE should be more than enough, right?

  • Connect PoE Ethernet cable first, then HDMI monitor cable. At first, the green power LED blinks, then after 15-20 seconds it turns steady and the blue activity LED starts blinking. The board boots up. The same test works the same if the HDMI cable is plugged in first, then the PoE Ethernet cable.

  • Connect USB-C power cable only. No Ethernet, no HDMI. The board boots without problems.

As I have 2 boards with 2 PoE hats now, I performed all tests on both boards. One boots from eMMC, the other from micro SDHC. There was no difference in test results between boards, so it is not a one-of problem. Also, I ran one last test, just to see if it will work.

  • Boot with HDMI and PoE Ethernet cable, then disconnect monitor. The board kept running, without problems. I could connect over SSH and even a reboot worked without problems.

Which all leads me to believe that it is a PD negotiation problem between the PoE hat and my PoE switch. As I mentioned in a previous post, the switch is a UniFi US-8-60W and supports 802.3af PoE type 1. The spec sheet of the switch lists:

Max. PoE Wattage per Port: 15.4W
PoE Output (Ports 5 to 8): IEEE 802.3af 2-Pair (Pins 1, 2+; 3, 6-)

So I tried to see the requirements of the Rock Pi 4b… All listings show what type of power supply it accepts, but not what is the minimum required (all on the Getting Started wiki page). The PoE hat wiki page states PoE 802.3at up to 21W (5V/4.1A), but also no minimum. So what is it? 18W??? Is my board getting some minimal power from the EDID pins of the HDMI monitor to just bring it over some brownout threshold and allow it to start booting? Is there somewhere in the logs after it boots, where I could see if the processor is underpowered?

Any hints would be greatly appreciated! Thanks!


Hi, @tnt

We have reproduce here in our office. For the PoE switch, we’ve tested the one from TP Link so far. It works without issue(Simply plugin the RJ45 cable and boot). Do you have multimeter? We will test more info to measure on the PoE HAT on Monday.

Hi jack,

Yes, I have a multimeter available. Standing by for further tests…

Could you please share the model of the switch you tested with? I would like to have a look at the manual.


Hi tnt,
did you solve your problem with PoE hats? If so, how you did it?
I have something similar. My PoE hat switched on just once but never again in any configurations independent from HDMI :frowning_face:

Hello DimAnt,

The solution was to try a different PoE supply. It seems, that the original switch I tried (an Ubiquity 8x switch with 4x PoE) did not have the right combination of voltage+current for the PD downstream controller on the Rock Pi 4B. So I tried using a PoE port injector instead and that worked. Since then I have not tried to connect to the original switch, even though it received quite a few firmware updates since then…

1 Like

Thank you, tnt.
Can you please give any info about your PoE port injector working well with Rock Pi 4B.

Hi @DimAnt,

The PoE injector is the one that is supplied with the Ubiquiti NanoHD wireless router. I was not using it to power the router, so I tried it with my Rock Pi 4B and it worked well. According to the NanHD datasheet, the adapter is Ubiquiti Gigabit PoE Adapter (48V, 0.3A) (Model # U-POE-af), which is also sold as a separate product. Here is a link to the data sheet of all Ubiquiti PoE Injectors, which lists the specs of the U-POE-af as well.

Hope that helps.

1 Like

Hi @tnt,
Today I have bought the same device as yours: Ubiquiti Gigabit PoE Adapter (48V) - and it really works from box! Thank you very much!
For any guys planning to use PoE. Be careful. My previous PoE injector Tenda PoE30G-AT has very similar specifications and declared to support IEEE802.3af and IEEE802.3at protocols. But it doesn’t work with Rock Pi 4B PoE hat in practice.