Rock Pi 4b+ unable to enter maskrom

Following the wiki:

I am unable to boot in maskrom mode. I wish to install images to the eMMC and need to do it this way because the eMMC is soldered.

I have tried on both Windows and a RaspberryPi with Ubuntu server 64 bit on it. I am using a USB-A to USB-A cable, labeled as 2.0 (if that matters). It is being connected to the upper blue USB port (What side is it for upper? I tried both). Powering the device is made with a USB-C cable to a powersupply (If that matters). As troubleshooting, not releasing the button under the USB-C port prevents the Rock Pi 4B+ to boot into the eMMC.

I dont seem to have any error, it just boots into the OS in the eMMC after releasing the button under the USB-C port.

Steps I am performing after the drivers installations described on the wiki:

  • Plug USB-A into computer’s USB 3.0 port.
  • Press the button under the USB-C port, hold.
  • Connect USB-A into the upper USB 3.0 port on Rock Pi 4B+.
  • Plug in USB-C cable for power (Green light lights up).
  • Release the button under the USB-C port (Have done this at very different times).

Eventually the eMMC OS kicks in (kinda fast catually). At any poiunt neither lsusb, rkdeveloptool ld, AndroidTool.exe nor Windows’ device manager show any difference or update.

I would also like to know how to boot to an SD instead (as a workaround).

What other troubleshooting steps can I provide? # Logs after not attempting to enter maskrom.

1 = Reset
2 = Maskrom

1 Like

That does work. Is there a way I can update the Wiki? I don’t seem to have permission.

Thanks for the contribution. You need to register the wiki to edit it.