Rock Pi 4 Plus will not boot from EMMC


I have tried everything on this forum and more. Flashed SPI, used RKDevTool to flash new Images on EMMC (onboard). Device is recognized in RKDevTool (maskrom) and I am able to flash a loader and image, but nothing works. I have cleared and reset the device several times.

Rock Pi 4 Plus will not boot to anything from EMMC. I only have 8Gb SD cards lying around and also put images on there using Etcher but I guess that also doesnt work with 8Gb is that correct?

Is there a way I can test the Rock Pi if its broken or something? Please help.

Added info: Now my keyboard and mouse are on but my monitor keeps turing on and off. It looks like boot fom EMMC is in a loop. Any thoughts? I have wiped the whole unit through the RKdev method erase all. Have tried Debian buster, Twister 2.0.3 and Armbian. Can someone maybe share a working image?

What version of the board are you using (e.g. Rock Pi 4 Plus V1.73)? I too am having very unusual issues that I can’t attribute to any obvious cause. Tried Radxa Debian builds, Armbian, DietPi. Have you tried accessing the serial port over the GPIO pins (USB to TTL)? I’m curious what you see there.

Just saw there was a production issue with the Rock 3 in the other forum and can’t shake the feeling that something is up with the hardware.

Hi Taylor,

I have in fact the Rock Pi 4 Plus V1.73

Using RKDev tool in Windows I get no further than green light and blue light flickering and my monitor turning on and off again after no input signal message. Depending on the firmware I use, sometimes the blue light does not go on at all.

I have even installed a dual boot Ubuntu and tried if I could get to the Rock Pi via Linux method. But now I am stuck at the last “make” command from the tutorial because it has no such file or target and seems to be outdated? Is this tutorial still working for other people?

In linux right now I have (cmd lsusb) the Rockchip visible stated as a RK3399 in Maskrom mode but bc of the last “make” command from tutorial not working I cant get to it.

Also I tried the same with 4 different micro sd cards, it will not boot from micro SD either and asll combinations of shorting and not shorting pins I have tried. I have not tried the USB to TTL yet because I have no experience with that but I will prbably try that next and after that give up and destroy this thing.

I was having same issue on my Rock Pi 4B+ 1.73 a few days ago, and I found a comment tucked away with a suggestion that worked. If you were following the wiki and it says /dev/mmcblk1 actually use /dev/mmcblk2 and try again, it works just fine as I have been able to flash both Debian Buster and Android and boot it from emmc after doing that. Here is the link to the wiki on how to flash it, use option 2 Rockpi4/install/eMMC - Radxa Wiki

Use /sbin/fdisk -l to find the mapped disk correctly