ROCK PI 4 Model B+ Green, No Blue, No HDMI

After waiting months for my ROCK PI 4 Model B+ 4GB / 32GB it finally arrived today.
I flashed the latest Debian OS from
to a 128Gb microsd card and put it in. I used Etcher as described at:
and verified several partitions were created in Disk Manager under Windows 10.

I plugged the keyboard, mouse, and hmdi cables in from a working Windows desktop. Then I plugged a QC 3.0 charger in with a USB C cable, and got the green light and nothing else. No video, no BIOS messages etc. The ASUS display just falls asleep after not detecting any video. I plugged in an ethernet cable, and noticed the orange traffic light blink, but did not see a new IP address show up on my rather long arp table. Does the BIOS get a DHCP lease for shh?

Did I get a defective board, or am I missing something?
I’ve tried several power supplies and USB cables.

I’ve looked at several other posts, and am pretty sure I have a good HDMI cable, and have not seen the blue light, which I assume would be near the green?

there is no bios, there’s uboot and i doubt it has a dhcp server running.
there’s something to do with SPI, ive had problems before. there’s a jumper at the end of the board. look up the wiki and play with that, i believe that area solved my issues.

1 Like

Thank you very much. I’m pretty new to single board computers. What is SPI?
Could you be so kind as to provide a link to the page in the wiki that talks about jumpers?
I’m having a hard time finding my way around in the wiki.
My board didn’t come with any jumpers. I didn’t think they’d be needed for normal basic booting.
I’ve found a few diagrams with code names for the pins, but nothing that really talks much about how they are used to configure boot options.

I don’t know how uboot differs from a typical bios. I’m guessing what ever firmware is on the board doesn’t have a video driver for the HDMI until an OS is loaded? That sure is not like my Rpi 4.

From what I see at
uboot is for booting from network, or M.2 SSD, but I’m not using either.
I’m trying to boot from a microSD card.

I found the problem. I didn’t scroll down far enough in the list of images to get the right one for my board.
Oops! It might help to add the file nomenclature to the getting started guide. I’m better at following directions, than guessing at file name conventions.

'Reflashed, and now I can boot at least. Now to copy the OS from the microSD to the eMMC.
Is there a config file to show boot progress?

I’m glad you got it worked out. I’m not sure about the config, it’s going to be different depending on the distro you are using. For the Pi 4B+, I recommend using the images found here
You have to manually install the desktop environment, but it’s mainline linux and will be much more stable. It also shows the uboot info on startup plus the kernel ring during loading linux.
If you are new to linux, then dont do that.

1 Like