Rock Pi 4 B v1.4 - can't boot it up

Hello!

Got my Rock Pi 4 couple of days ago. Was very excited. And I just can’t boot it up.

I tried:

  • 3 different microSD cards.
  • 6 different images (Armbian, Manjaro ARM minimal / KDE, Ubuntu Bionic, Debian Stretch, Android) found on the Radxa download page and in the wild Internet and burnt with Etcher.

When I plug the power, there is a bright green LED. But then nothing happens, I waited about 2-4 minutes on each image. HDMI output is black, no other LEDs blinking. Network LEDs are blinking but my router doesn’t see any new device.

I also tried to flash SPI using the guide from wiki. I can see the device in maskrom mode (with rkdeveloptool and lsusb), but when I trying to do anything with rkdeveloptool, it just stucks, even with “rid” or “rd” commands. No error, no result, nothing.

I don’t know my wall charger supports QC3 properly, I don’t have any QC-enabled devices. But the box stated QC3 support and there is 9V/2A mode, if letters on the charger don’t lie.

Please, can you help me boot it up or detect a hardware / software problem? Thank you.

Does the light next to the green light blink?

No, there is only one non-blinking green LED, I didn’t see any other LED to be turned on.

Behind the USB, there is a switch, high level is in device mode. Please switch to H, execute lsusb and tell me the result.

Like this?

lsusb entry:

Bus 002 Device 006: ID 2207:330c Fuzhou Rockchip Electronics Company RK3399 in Mask ROM mode

rkdevelop:

$ ./rkdeveloptool ld
DevNo=1	Vid=0x2207,Pid=0x330c,LocationID=202	Maskrom

# ./rkdeveloptool rid
^C because nothing happens

Maybe the sd card socket is broken. Do you have an emmc ?

No, I don’t have an emmc card. But I also ordered an nvme disk with board, not delivered yet tho.

Is it OK I can’t do anything with rkdeveloptool?

Might help: Install on M.2 NVME SSD

Thank you. But according to this article I should have either a running OS or flashed SPI to boot from nvme. I can’t do neither:

  • I don’t have a running OS because of potentially broken SD slot or another issue.
  • I can’t write SPI flash because of rkdeveloptool freezes when trying to process any command.

Hi,

One thing to note:
The SD card should be inserted facing up towards the board.

To be sure, which option is correct, 1st or 2nd?

1st option…

Well, I’m doing it right.


I found something. I ran rkdeveloptool on another Linux (Fedora) machine and it fails on each command. I tried rid, rd, rci. Every time I get <command> failed!, like, Reset Device failed!. rkdeveloptool ld and lsusb are showing the device with correct VID & PID. Switch is in H (device) mode.

Is my Rock Pi dead?

Hello,
I have similar problems and I checked the several hints made before:

Hint: Does the light next to the green light blink?
Answer: No
H: Behind the USB, there is a switch, high level is in device mode.
H: Please switch to H, execute lsusb and tell me the result.
A: Switched to H - nothing, can’t execute lsusb because system doesn’t boot
H: The SD card should be inserted facing up towards the board.
A: Correct side up, as shown

In addition: checked HDMI-Cable and connection: Ok, works good with another Linux-machine …

I had inserted an EMMC-Card. In this case appears a message after connecting to power:
“please download + write os image to the eMMC module from rock.sh/pi4 …”

I use a Rock Pi 4 zbh Power Adapter QC 3.0 EU

My conclusion is:
power connction works
eMMC Port ok,
SD-Port damaged.

Am I right??

Regards

Wolfgang

Hello,

I have to correct:
Hint: Does the light next to the green light blink?
Now my answer is: yes
I flashed an armbian-image to my sd-card

Any other advice how to boot and install on my Rock PI 4 B??

Thanks in advance.

Regards Wolfgang

Hi,
good news. Just switched back to my linux-monitor. Everything running, I could login to the armbian start-login.
I think I was too impatient …
Regards
Wolfgang

What I found is impossible
Writing the SD card using dd failed to make a bootable card
Writing the SD card with etcher DID make a bootable card.
This is so bizare that I checked 3 times using different block size
dd if=rockpi4-debian-stretch-desktop-arm64-20190730_2022-gpt.img of-/dev/disk2 (whatever you device is) bs=1M (tried 4M and no bs entry)

1 Like

Use dd with conv=fsync ???

I was having similar issues with android i used etcher to make the image on sd card didnt work then i used 7zip to unzip the android 9 image and used that “the unzipped iso” and it booted perfectly the board even corrected the kernel im guessing from when i ran debian on it which didnt work out because the desktop was too wide and i couldnt see the panels or edges “can anyone help with that?”

anyways hope this helps.