Rock 5B Virtualisation

Hi There,

I was trying to create virtualisation in Rock 5B, but I realised that the CPU doesn’t provide virtualisation. However, it was so close to completing the installation of windows on QEMU, and Boxes.

Is there any possibility of creating a virtualisation in ROCK 5B. to install windows and other OS?

Many thanks in advance!

What do you mean when you say that it doesn’t provide virtualization? It’s a feature of the armv8-a architecture, so it must.
People have successfully installed proxmox, but you can use any host OS.

I have a 2 node 16GB Rock5b ProxMox cluster running now! I have also deployed a debian 12.1 VM.

I will add additional information once I have my notes straight & a completely solid recipe.

2 Likes

https://wiki.radxa.com/Rock5/downloads

This image https://dietpi.com/downloads/images/DietPi_ROCK5B-ARMv8-Bullseye.7z

Install OpenSSH Server ( My Preference over dropbear )

dietpi-config

Network Options: Adapters

Turn off IPV6

IPV4 Turn off DHCP & copy current settings to static

nano /etc/hostname ##set hostname

curl https://raw.githubusercontent.com/pimox/pimox7/master/KEY.gpg | apt-key add -

apt update

curl https://raw.githubusercontent.com/pimox/pimox7/master/RPiOS64-IA-Install.sh > RPiOS64-IA-Install.sh

chmod +x RPiOS64-IA-Install.sh

from hard wired console ./RPiOS64-IA-Install.sh

from hard wired console after reboot —> apt upgrade -y

reboot

===========================================

References:

Guide https://pycvala.de/blog/raspberry-pi/raspberry-pi-installing-proxmox-ve-7-on-the-pi-4/

Container
https://uk.lxd.images.canonical.com/images/ubuntu/jammy/arm64/default/20230830_07:57/

VM Images
https://cdimage.debian.org/debian-cd/current/arm64/iso-cd/

3 Likes

longshot, but have you tried to pass through the gpu?

@shelter ARM64 SoC:s do support virtualisation.

@flyingRich Sorry the instructions you shared are a bit unclear.

Radxa’s Debian distribution for Rock5B appears to bundle a KVM module but it’s not loaded by default.

Has anyone had success with running KVM VM:s on Rock5B?

QEMU and LibVirt work equally well?

I have tried using KVM and it seems to work but I couldn’t get windows ARM to boot: Actually booting Windows 11 using a KVM virtual machine
Libvirt and KVM themselves work pretty fine, there just seems to be a problem with UEFI. I managed to boot Windows XP, Ubuntu x64 and Windows 7 using qemu. Haven’t tried native KVM with a Linux distro but I think it will work, you just might need to turn the a55 cores offline (there is a way, search for it).

Proxmox has basically the same functionality as Virt-manager but as a webUI

Why would you need to disable the A55 cores to use KVM?

Could you share the QEMU command line you used to launch installer and launch the machine

I think the spaghetti qemu commands are a bit useless and prefer to use Virt-manager, but if you really want I can find out and share it (but I couldn’t get Windows to work anyway, so I don’t know of what use it would be). As said above, the systems that worked used QEMU emulation, not KVM, but I expect the problem with Windows was not with KVM itself but with UEFI being badly implemented in libvirt.

As for why the A55 should be disabled - I’m not sure, it was in one of the tutorials I found. Might be related to this: https://forum.pine64.org/showthread.php?tid=18202 (A53 and A72 here). Or this: https://patchwork.kernel.org/project/linux-arm-kernel/patch/20191216115631.17804-4-steven.price@arm.com/

What is your question?

If I Can post a video, I will.