Rock 5B not booting - black screen

I’ve bought a brand new Radxa Rock Pi 5B, but it doesn’t seem to be working. All I get is the green LED constantly on, no signal on either HDMI port. The power buttton has no effect.
I’ve tested it with 2 power adapters: HUAWEI HW-200325EP0 and Anker A2663 - both are on the Radxa wiki list of supported power adapters.
I’ve tried with and without the SSD disk.

Any suggestions what could be causing this ?


First you should remove any “extra” HW like SSD and EMMC, USB3 and try to boot from SD-CARD. Ensure you have a Distro for the Rock-5B. If that does not work, you could try RkDevTool to see if the HW is alive.

Well I already disconnected everything, including the sd card. Only power and HDMI connected. So I would expect a “no boot device” message, or?

No. This is not a PC. The bootloader has no support for a GPU, but only for a serial console and only if enabled, which seems to be not the case with standard Radxa loaders. HDMI is initialized only after a kernel booted, so until that, visually “nothing” happens. Most bootloaders and kernels use the blue “user” LED to give a live sign: it is typically ON once the SD-Card is read, and blinks when the kernel is loaded.

Hence, write an image for the ROCK 5B to a SD-CARD, insert it, power on. Start with the official Radxa image maybe ( If the BLUE LED is switched on, GOOD, the is read. If it starts blinking, GOOD, the kernel has started. Even then you might have no image on HDMI, for instance if you use an adapter cable (HDMI->DVI does not work on ROCK 5 most over the time). Use the HDMI port that is near to the USB input. If you have boot loops (blue LED on, blink, OFF, ON, blink, OFF) your power supply does not deliver enough current, try a 5V 4A “dumb” one).

OK, thanks. I’ll try that. I expected it to work more like raspberry pi, which displays information when there’s no boot device.

I’ve tried booting from SD card without luck. However the behavior is different - now the green LED is on, blue LED blinks twice repeatedly. Nothing on the screen.
I’m really disappointed with this Rock 5B :confused:

This blinking twice is called “heartbeat”. It probably means the kernel is up and running, just no video output. There might be different reasons for it. Try to ssh into it. Depending on the disto you boot, different password might be the default, AND because WiFi isn’t configured, works only over a wired connection. Just connect and look into your router, if a new device has appear. I don’t know what the default name for the Radxa images is. If you found it, try ssh. If that works, post the output of dmesg. You might also try the other HDMI port.

PS: I use the Rock5B as my default desktop machine, so once it is running, it’s nice hardware…

So, I made it to work… until it stopped working
I’ve tested RebornOS, but didn’t like it, so I went with Ubuntu 22.04. And everything was working fine, but after a while I’ve powered it on, and I’m back at the green solid LED.
And nothing has changed since I shut it down the last time.

Hi, I am an amateur in these things.
But I like the hardware and like to use Android 12 on this SBC.
How to put it on?
Is there an installer of Android 12 that I can boot from SD card?
And install it on SSD?
Sorry for this basic question.

I had this when upgraded to new kernel. Did you run an update (maybe silent)?

Mine booted, there was some kernel logging as it booted up and right at the end an error flashed up, then black screen as well. Connect a keyboard, press alt+f2 to open a second TTY and it shows a login prompt just fine. My guess is the software that was preloaded is broken and I’m going to try to reinstall. I only added an NVMe drive, I could try removing it see if it boots without the NVMe connected.

Before I’m going to do anything drastic and reload the eMMC, I am seeing the device on my network, so I’m going to try SSH’ing in and have a look around roobi OS.

Actually I don’t know how to login to roobi os over SSH, don’t know the credentials.

I might have no choice but to reflash it.