[Rock 5B] 980 EVO SSD SATA

This is not samsung. This is fake chineses drive. It is around 80 GB in real. But nevertheless it does not matter. This is ngff drive that will not work on Radxa Rock 5B.

Ok, i will format the driver on PC box and see what i get. At least it displayed 1.8TB.

Anyway, Hope we get some input from Radxa to end this thread.


just look page 18 of the shematic there is the combiphy thing and the sata pcie usb3 settings

and no it is not compatible witth just plugging drive you would have to make a custom converter

you have to disable a pcie lane or a usb3 lane and enable sata o or 1 in the dts for enabling sata

it just the same as gpio has multiple pin config ,and with pcie/sata/usb3 it is with combiphy

the dts


the adapter

and you can just look at the pinout of ngff and the pinout of the raxda pcie that it is not compatible

This is for the M2 on TOP of the board. sata1.
Making a custom converter is beyond my knowledge, unfortunately.

Today i received my 2TB 980 EVO SSD SATA M2 2280 which claims sequential read/write speeds up to 3,500/3,000 MB/s .

This is as fake as fake can be. There is ABSOLUTELY no way that NGFF (SATA) has such speeds. The NGFF (yes i have also one running in my computer) has speeds to a max of 600 MB/s (SATA3).

[<USER>@K-PC ~]$ sudo smartctl -a /dev/sda | grep 'Device Model'
Device Model:     Samsung SSD 860 EVO M.2 2TB

The speed of my Samsung SSD 860 Evo M.2 NGFF (SATA) 2 TB)

 Timing buffered disk reads: 1592 MB in  3.00 seconds = 530.18 MB/sec

As far as i know, they dont make any m.2 SATA (NGFF) anymore, as almost every device supports M.2 NVME which is much…much…much faster. In the past i used the current M.2 SATA NGFF in my Raspberry Pi 4 (through USB 3.0 Adapter), but now i am running my Desktop OS on it as it does the job and dont want to put it aside.

This is by the way the speed i got on my Samsung Evo Plus M.2 NVME 970 2 TB. That is by the way while it is already in use.

 HDIO_DRIVE_CMD(identify) failed: Inappropriate ioctl for device
 Timing buffered disk reads: 3948 MB in  3.00 seconds = 1315.63 MB/sec

This is 100% fake ssd on screenshot so.

If this were the only problem i would be happy. :smile:

Ubuntu (Kernel 5.13) reports 1.88TB, NTFS file system type. I formatted it with ext4, Ubuntu displayed the formatting process nicely and reported 1.88TB in size, but still NTFS/exFat.

It seems the controller cheated, or just marked erased. I gave the ssd to a Windows guy to test it on his AsusRock board but AsusRock put the M2 socket right beside where the GPU is attached, and he needs to disconnect the GPU to plug in the SSD, i don’t know if he is willing to do that.

Buy cheap buy twice, but buying an expensive motherboard does not mean is well designed.

Can you answer the question about the SSD having power by just inserting it into the M2 slot?
In the PC box, when i turned it on, there was a red led on, BIOS rebooted the PC and a second red led blinked, i think it was when BIOS detected the SSD.

Is it the same with ROCK 5B?

NGFF is the abbreviation for ‘next generation form factor’ and this is how M.2 was called in the beginning. M.2/NGFF is a physical connector/standard able to carry many different protocols. As such NGFF is neither SATA nor NVMe but the NGFF/M.2 connector could carry both.

On Rock 5B only the key E slot can be turned into SATA since this slot is behind one of the three Naneng Combo PIPE PHYs. The key M slot is PCIe/NVMe only.

No need to give it to a Windows guy since the h2testw equivalent also exists for Linux: https://fight-flash-fraud.readthedocs.io/en/latest/

Many mainboards can deal automagically with both SATA and NVMe SSDs in the M.2 slot and the same goes for some USB enclosures based on RealTek RTL9210B-CG or JMicron JMS581.

Look up PEDET here for example: https://www.congatec.com/fileadmin/user_upload/Documents/Application_Notes/AN43_M.2_Pinout_Descriptions_and_Reference_Designs.pdf

There’s no such thing with Rock 5B…

Right. According to Anandtech:

NGFF Card Format* defines:

  • Two SSD host connectors
    • Socket 2: …
    • Socket 3: 4x PCI Express up to 4 GB/s fits
      modules with the “M” key …

My PC motherboard (gigabyte) has M2 slot, the same as M2 slot at bottom of Rock 5B (including physically - visually), so socket 3.

If i understand correctly, the SSD will communicate as a device with M key. The problem is there is no power on the SSD, on the SSD device there are two red LEDs, one is power, and the other is communication with the controller, i think.

The power LED is not ON when attached to the M2 socket (Rock 5B). I changed to sata0 but this breaks PCIe 2.5 ethernet. And still no power. no red LED ON.

This is stuff from the past. The new socket was called NGFF back then but after standardization happened is called M.2 now and socket 2/3 have names (those funny keyings and so on).

RK3588 has five PCIe controllers and three Combo PIPE PHYs. Of these three latter things the first is routed to the RTL8125BG chip, one to the key E slot and the other to USB3. As such as you experienced if you turn just a random PCIe Gen2 lane to SATA (sata0) things break (the RTL8125BG is only PCIe capable and if you change the PHY mode to SATA it will get disconnected).

The only two ‘slots’ where you could get SATA signals are the key E slot and one USB3-A receptacle. In both cases ‘all’ that’s needed is a DT overlay and some custom made adapter for your B/M keyed SATA SSD.

The M.2 key M slot has no SATA capabilities whatsoever so simply forget about inserting a SATA SSD here. It will never work and power is the least problem. The only way to bring the key M slot together with SATA is by slapping a SATA host controller into and by wiring your SSD to this thing (maybe on Aliexpress M.2 SATA host controllers exist that feature another M.2 slot to insert a SATA SSD).

BTW: the keying also has no direct relationship to the physical protocol layer since key B is specified to carry ‘PCIe ×2, SATA, USB 2.0 and 3.0, audio, UIM, HSIC, SSIC, I2C and SMBus’ and key M is able to carry ‘PCIe ×4, SATA and SMBus’.

And there’s a reason nowhere NVMe is mentioned since NVMe is the storage protocol above the physical layer (that is almost everywhere PCIe with NVMe, with SATA the storage protocol is always AHCI but a decade ago PCIe SSDs that relied on AHCI instead of NVMe were a thing).

TL;DR: the way Radxa decided to route the available PCIe/SATA lanes there’s no way to get any SATA SSD attached directly into the M.2 key M slot to work. Since this slot is unable to be turned into SATA. This is both Rock 5B and RK3588 specific and what happens on mainboards or somewhere else is irrelevant :slight_smile:

Check the SSD for fake capacity with f3 and then use it somewhere else unless you’re willing to build/use mechanical adapters and then attach the thing to the key E slot or USB3-A.


I bought Patriot M.2 P300 256GB and it works like a charm.
Here’s a hdparm benchmark on a running ubuntu focal image:

Timing cached reads: 8120 MB in 2.00 seconds = 4063.56 MB/sec
HDIO_DRIVE_CMD(identify) failed: Inappropriate ioctl for device
Timing buffered disk reads: 3584 MB in 3.00 seconds = 1194.56 MB/sec

Interesting, here it is rated read 1700MB/s, write 1100MB/s with good price.
The only problem i see is if i start compiling things, it will be filled up in 2 months…:smiley:
Never mind, what is important is the TBW: Up to 960GB.

A time back i saw a video about a external SSD drive that was bought on a chinese website. These guys are not dumb. They know how to work the controller firmware and put some microsdcards in it to fool everything.

About SSD having power by just inserting it into the m.2 slot. Both the M.2 NGFF (SATA) as well as M.2 NVME use very to almost no wattage. So you do not need extra power to make it work. The only difference is for example with a M.2 NGFF (SATA) you need to connect it to a SATA port, while the M.2 NVME uses the PCI slot itself for connection.

And yes with the Rock 5B, you just put the M.2 NVME in the M.2 slot and it works. At least the Samsung 970 Evo Plus NVME SSD of mine.

You are comparing benchmarks with random numbers generated by hdparm (which was a benchmark last century but not today any more).

This is 5 times hdparm with a cheap Kioxa consumer SSD (the junk currently mounted on my Rock 5B):

Timing buffered disk reads: 622 MB in  3.00 seconds = 207.27 MB/sec
Timing buffered disk reads: 1506 MB in  3.00 seconds = 501.95 MB/sec
Timing buffered disk reads: 2670 MB in  3.00 seconds = 889.99 MB/sec
Timing buffered disk reads: 4894 MB in  3.00 seconds = 1630.62 MB/sec
Timing buffered disk reads: 4242 MB in  3.00 seconds = 1413.98 MB/sec

First two are with cpufreq on lowest setting, next two with cpufreq on the highest setting. Always a little core first followed by a big one.

With Radxa’s OS images until recently (see here for details) and with Armbian still and most probably forever the needed tweaks aren’t applied to ramp up CPU clockspeeds with I/O workloads. As such with hdparm in ‘fire and forget’ mode you’re ‘benchmarking’ the cpufreq scheduler/governor more than storage. And as can be seen above this makes a difference of 210 - 1630 MB/s.

Last check above was with default settings (random behaviour based on what scheduler and cpufreq governor do). Are these 1413.98 MB/sec the ‘drive performance’?

No of course since hdparm uses a block size from last century (128KB were huge back then when Linux developers added the -t and -T switches to the tool when they dealt with spinning rust attached to an IDE interface or worse). And also the --direct switch was missing.

Today we should check with 1M or better 16M. With my junk Kioxa SSD this then looks like this using taskset -c 4 iozone -e -I -a -s 1000M -r 16384k -i 0 -i 1:

          kB  reclen    write  rewrite    read    reread
     1024000   16384  1046735  1047446  2572526  2582696

That’s more close to ‘drive performance’ than misusing hdparm. 1000/2600 MB/s write/read.

OMG, these SBC forums…

Please stop posting such nonsense. NGFF is how M.2 was called. It’s a mechanical connector, nothing more, nothing less. Just think about to which page this link redirects: https://en.wikipedia.org/wiki/NGFF

Bro chillll… i am talking about something like this, which i use in combination with my M.2 NGFF (SATA) ssd. It has mSATA, M.2 NGFF (SATA) & M.2 NVME

I have an M3 Station board with RK3588s processor that works with m2 sata by default but can also work with M.2 NVME depending on dtb, I tried it personally. I saw that it works with the m2 to sata adapter, so it should work. I didn’t try it on rock 5b because it has a lower speed…

sure m3 is faster because of the s of super :rofl:

there always be a adapter board to get sata out of the pcie lanes on top and bottom and a dts change

and i saw this and that doesnt help ,and pc this and that doesnt apply to a sbc .

M3 Station cannot work on 4 pcie buses because it does not have them and then it works better on m2 sata.
sure m3 is more expensive because of the s of super :rofl: