Rock 5A no I2C or UART output

hello all,

i have a Rock 5A v1.1 running rock-5a_debian_bullseye_cli_b18, and have enabled i2c on pins 3/5 (I2C2_M4) using the rsetup tool. then i try to probe the i2c line by running sudo i2cdetect 2 and connecting an oscilloscope to pin 3 (I2C2_SCL_M4). the oscilloscope does not show any signal at all.

I’ve also tried I2C8_M2 and UART2_M0 (using sudo minicom -D /dev/ttyS2 -b 9600 to write to the pin 8 TX line), but there as well: no signal measured with an oscilloscope.

am i missing some setup steps? is my device defective?

interestingly when i run the view overlay info tool in rsetup it says that I2C2_M4 is on pins 21/19 which would be correct for the newer board revision V1.2 and not my V1.1. anyways, no clock signal on those pins either.

Welp, you’re not the only one.
First, there’s no V1.2 that I know of.
Your V1.1 is similar to X1.2, so if you were looking at X1.1 pinout on wiki and thinking that it’s correct for you — well, it’s not… Try actually referring to X1.2 pinout instead.
So, pins 3 and 5 on your V1.1 are, in fact, I2C8_M2. That said, there’s one more issue: the schematics available for download (and the info on wiki) is wrong, as there’s pull up on SCL but NOT on SDA for I2C8.

thanks, that did the trick! i must have messed something up before as i could have sworn i had tried out I2C8_M2. but indeed, there doesn’t seem to be a pull-up on pin 3 (I2C8_SDA_M2)…

for future reference, my steps to get i2c to work were:

  • add a 2.2 kOhm pull-up resistor between pins 1 (3.3V) and pin 3 (I2C8_SDA_M2)
  • run sudo rsetup -> overlays -> manage overlays -> enable “I2C8-M2” with [SPACEBAR] -> sudo reboot
  • check that i2c works with sudo i2cdetect -y 8 and a connected scope to pins 3&5 yields the following:

    the sawtooth pattern is a bit strange (insufficient filter cap on 3.3V?), but i guess it doesn’t influence operation.