Rock 4SE not working

OK, the problems with Raspberry pi supply chains did have me looking into this new competitor. Great reviews, good feedback, these guys at Radxa out of China are brilliant to have developed such a SBC.

I bought three 4SE boards, I got all three working ! But … not entirely. If I could pinpoint a single issue I would be asking for help, but I cant, as every time I started them up, a different problem occured. e.g. didnt reboot (required 5 to 6 tries with power plug reconnection). "sudo apt update sudo apt upgrade " failed so many times I could not count. HDMI connection, wifi connection worked, then it didnt, then it did, then it stopped altogether, requiring a new image flash of the uSD card.

I probably spent around 100 hours on all three boards before giving up. I thank you guys again at Radxa, but I would not be taking my consumer rights seriously if I didnt rate your product as “not ready for commercial use”.

I have been using a ROCK 4 SE for some time. I agree it was not easy to power-up, it needed a good power adapter, or a high quality DC/DC converter to power directly to the +5V pins. I could only get Debian xfce (RadXa official release) to install and be useful with a 1280 X 800 HDMI monitor. Here are some problems that I have not resolved:

  • Geany installs, but it will crash occasionally especially during file operations.

  • One of my C++ OpenGL applications that run OK on my Linux PC will crash with segmentation errors, sometimes just using the keyboard (when in focus) would provoke this.

  • Various problems with mraa and PWM, but maybe these are generic and I have resolved these - see my other posts!

  • My applications run slowly and irregularly. Using Htop all 6 cores are being used etc etc. The CPU runs at 60deg, so that’s good.

I have now just bought a ROCK 4C-plus - and all the problems above are solved! So I would definitely not recommend the SE version! The 4C-plus has a a much better PCB layout with the CPU on top so it’s easy to stick a heat sink to it, and a very useful power switch. It is so much better than a RPi - and the price has just reduced!

Hiya bnsearle,

A very informative reply. I am so glad you got it working with the 4C+ !!

I am still sad however, I spent nearly 1000 USD on the Rock Pi, 3x 4SE + all the accessories. And yes I did have a 12V power supply, even tried with 9V, didnt make any difference.

I could continue this discussion with Radxa, but they would only be using me for free to develop their product, and I would be paid nothing and spend countless free hours trying.

I sorta feel scammed though, but you know, the RPi didnt work in the beginning either .

OK, I found a solution, a company near me bought a bankruptcy venture with more than a thousand Raspberry Pi units at reasonable prices. Of course I will not post their details here, just that I am going back to something that works. I would happily help Radxa develop their products, but they would need to come to my house and sit at my laptop, I am not going to lift a finger and put free effort into this.

I realise that such development projects are part of the community spirit, to develop, and grow and evolve. I mean we would not be here if we just wanted to buy a PC or Mac from the shelf, it would be too easy, and no fun. But there is a limit to this as well, its just wrong that Radxa sells products at premium prices and expects the consumer to fix their problems for free. It was a fun experience, but I am moving on to what works.