Rock 4C+ V1.41 cannot boot Armbian

Hello there,

I am trying to run Armbian image on Rock 4C+ V1.41.
I’m using download link for 4C+ found here:, specifically images from here:
They all are having 4cplus in names, so I assume target right board model.

However, it does not boot - I have steady green led and “2 short blinks - pause” cycle on blue led (though, it does it even when it boots fine, just at a slower pace), nothing on the screen.

I figured that 4C+ does not have SPI Flash, so not legacy bootloader problem.
I notice that armbian images, unlike radxa’s, are:

  • MBR
  • have single ext4 partition with boot and rootfs
  • they start their partition at 32768, where radxa’s images have FAT32 EFI boot partition

Would anything from this have to do anything with boot failure?

Any pointers on how to proceed would be welcomed.

P.S.: the reason I am trying to run Armbian is because of newer kernel. Radxa’s images boot ok but there is a bluetooth problem causing my BT keyboard to connect and immediately disconnect, and I was hoping to see if it is something that might have been fixed there. There is a topic on this forum describing the this problem with HID devices with no replies.

I recently installed Armbian on my Rock 4C+ for similar reason - the 5.x kernel - downloaded on 9th Jan. I initially tried the main Rock 4 image as it states that it is compatible with “ROCKPI 4C+” - it booted ok but no wifi. I then did the same as you, and downloaded the latest “rockpi-4cplus” via the “For Model C+ here” link. I guess it would have been

This worked fine (written to uSD using Raspberry Pi Imager) and is now flashed to emmc.

Login console message:
Welcome to Armbian 22.11.1 Bullseye with Linux 5.15.80-rockchip64

Works fine for me. On both 1.2 boards (with the PCIe), and 1.41 boards.

I think you’re supposed to just use the HDMI which is furthest away from the power connector.
Also I think they have the top USB3 configured as OTG by default still so not much use.

YES! This was it. Thanks.

It seems Radxa’s image initializes both HDMIs and Armbian only appears on the HDMI port closer (in my case) to the rest of the ports!

I did not spot this anywhere in the documentation so hopefully it would be useful to someone else.

1 Like