Rock 4c+ UART2 change default baudrate

I’ve activated UART2 because I need serial communication.
With a python script I’m sending out command from UART2 (ttyS2), but the data received on the other terminal is not correct. It seems that the baud rate from the transmitter (rock 4c+) is different from the receiver (also if I set the same baud rate and setting 8,n,1 in both transmitter and receiver).

My question is:
could this issue be solved by changing the default baudrate of the UART2?
Someone could suggest me how to change the default baudrate of UART2?

Thank you