ROCK 4 SE Support in Rockchip Debian SDK

We are trying to build a custom image for ROCK 4 SE with Rockchip Debian SDK. However I found that ROCK 4 SE support is not available in Rockchip Debian SDK. Can you please confirm, if support for it is available or not? If Yes which config file to use. Becuase I do not see any support for ROCK 4 SET in file, in uboot configs and kernel configs.

@RadxaYuntian can you help to give a answer?

The toolkit you are using is deprecated. Please try rbuild to build an image.

@RadxaYuntian Thanks for sharing the new build system. I have tried it and getting this error while trying to build image for rock-4se:

Please make sure you have enabled virtualization in your system per our documentation.

@RadxaYuntian I have already enabled virtualization but still getting same error.

You probably does not have the correct permission on /dev/kvm.

Please test the workaround listed here.

@RadxaYuntian I am using Ubuntu22 in virtual box and getting this error while trying to give permission to /dev/kvm

This is discussed in our documentation:

If you are building in a virtual machine, you need to enable nested virtualization, as KVM is required for building the image.

@RadxaYuntian but it is already enabled:

Please ask in VirtualBox forum for this question. Although this thread might be related to your issue:

@RadxaYuntian I am able to solve this issue and assign permission to kvm, I am building now, I will let you know about my progress:

@RadxaYuntian I am getting this build error:

Please use -T argument to select the test repo for now. Sometimes we make updates to package dependencies. This makes rbuild incompatible with the release repo, so you need to use the test repo which contains the updated packages.

We periodically sync release repo with test repo once the components have passed the internal QA.

@RadxaYuntian I am able to build image using test flag -T.