Rock 4 SE NAS - Not booting after installation

Hi all!

As a disclaimer, im very new to this world of SBC’s and linux so bear with me :smiley:

I wanted to try and build a functioning NAS with a Rock 4SE and the Rock SATA hat that fits 4 2.5" SSD/HDD.

I stumbled upon this guide (

However, when i try to follow along, the Rock 4 doesnt boot correctly after the reboot command.
It wont show up in my DHCP table, and if i stick a HDMI cable in it, the output shows a lot of failed boot processes.

I have tried a few different Armbian builds - both bullseye (The CLI build here and bookworm (Found on armbians github page - linked from armbians website under Rock 4), and it yields the same result.

Just this morning i read that the Rock 4SE is not sufficiently powered by a 5V USB-C power supply, which i had been using. Is it probable that this can cause it since the rock requires more power?

Can anyone point me in the right direction based on the information above?

You don’t need this hat to boot system and see if anything have changed. Armbian is great initiative, but often untested builds are released and they can stuck at boot, kernel panic or miss some important features such as fast pcie support. Start with simple things - bare board with system, some cooling and networking. Double check system stability and then attach HAT.

Please note that SATA HAT has it’s own power connector. You don’t need to use it if You power Your drives externally. If You want compact setup with drives directly attached to board You need at least 12V/4A simple power adapter with barrel jack. I don’t think You can power everything from ROCK board usb-c port. Power IC is designed for typical usage, four drives will need way to much.

Yet again - double check Your system before going further, please note that You need to switch into pcie 2.1 lanes with overlay and test that. As far I remember this was broken on recent Armbian kernel, maybe they have fixed it already, maybe not… this is important with such setup or You will get half speed.


Thanks for the in-depth answer!

So far i have tried booting it without the SATA hat with the USB-C power supply. But according to Radxa the 5v USB-C is not sufficient for the board itself even ( Perhaps this is a part of the issue.

The odd thing is that after flashing the image to a SD card the first boot and SSH works flawlessly. But when i reboot the board after running the apt-get update and apt-get upgrade -y command some of the boot processes fails.

I will try to connect the HAT without the HDD’s mounted and power it via a 12v 6a (Couldnt find a 12v 4A PSU) and hope that works

Hi again.

I manged to make it work with a different image. All is now up and running :smiley:

Quick question about the pcie gen you mentioned above. Does the sata hat support pcie gen 2 and is there any actual befits from trying to use the gen2 as opposed to gen 1?

For bare board with just sd card (or eMMC) many cellphone 5V chargers are ok. It’s get more difficult when You are connecting more usb and m.2. For sata board much more power is needed and that depends on type and particular model, but usually it’s 3-8W per drive.

It’s ok, extra power will not cause any damage, but probably You will get slightly higher power consumption on idle because all power adapters are not 100% efficient.

Great :slight_smile:

Something like usb3 vs usb2 :slight_smile:
You did not mentioned about Your SATA hat, but I assume it’s penta sata hat,
it’s based on JMB585 chip which is designed to connect with 2x lanes pcie gen3.
Each main pcie revision is about twice fast as earlier,
HAT will use two lanes with max gen available on both sides, in ths case 2x pcie 2.1 (if You turn it on). It should be able to archieve about 800M/s. On boards with pcie3 (like ROCK 3A) it will work 2x faster.

But Your benefits depends on drives. With older 2.5" hdd capable of 80MB/s probably You will not reach bottleneck. With SSDs at 550MB/s each even 2x pcie3 is limiting.

Again, thanks for the clarifications.
This is my first Rock/Pi project :smiley:

Im just using 4 2.5" HDD’s so i dont think i will fiddle around with the pcie generations when i wont be albe to utilize it.

You’ve been a great help, really appreciate it!

ok, just note that hat is capable of those speeds and board support 2.1 if needed, it just requires right kernel and setup. According to docs board by default uses gen1 for compatibility. SATA HAT is compatible and work great at 2.x and 3 with other boards capable of pcie3.