[Rock 3A] U-Boot - No ethernet found

Hi,

I’m trying to enable dhcp/tftp boot on the Rock 3A, however U-Boot is failing to probe the ethernet.
I’m using SD card, and I have tried building my own U-Boot from the radaxa u-boot github repo (branch stable-4.19-rock3), but I still get the “Net: No ethernet found” log.

BTW, most people’s 3A boot logs they post seem to have this same issue.

I tried editing the rock 3a dts to add the gmac1 etc. and set status=Okay, but no luck yet.
I did find one boot log in this forum with what looks like a successful Ethernet probe using g3163a2399b that is a bit older.
I tried to compile this older u-boot revision, but I get no output on the UART console at all :frowning:
I can’t find any definitive docs on compiling u-boot for the 3A, the docs in the repo don’t cover it, nor on the wiki so I’ve pieced together something, which could be part of my problem.

Any tips/recipe on how to get Ethernet working on 3A?

Note, the HW itself is fine, ethernet in Linux is working fine.