Rock 3A no power after SSD boot attempt


I tried to boot Rock Pi 3A via NVME SSD.

Since I don’t have USB cable to connect to SSD (to write image) I did following steps:

  1. Wrote official Debian image to SD card.
  2. Successfully booted Rock Pi 3A with the image.
  3. Inside the Debian, I downloaded the same image(this time saved it in the device memory in the SD card).
  4. Then used approach mentioned here:
    sudo dd if=’ your image path’ of=’ your NVME SSD device path’ bs=1M
    Even though instructions are from RockPi4 page, since it is OS related instruction, I thought that it should work fine with RockPi3 as well.
  5. Then I removed SD card, and powered the device with SSD installed - nothing happened(no power).
  6. Then I tried to power with both SD card and SSD installed - nothing happened
  7. Then I removed the SSD and tried to power only with SD card - nothing happened
  8. I rewrote fresh image to SD card and tried this way and again nothing happened.

Device is currently unusable. I noticed that the green led on SBC is not being powered as well. Though when I measure the input power on the board, I can see that 12V is present, so power is coming, but I guess not going further into the system.

According to the schematic POWER_LED is powered through SoC PMU, does it mean that issue is in PMU?

Any tips to troubleshoot?

Just want to note that I don’t have eMMC module.
The SSD model that I used: (250 GB version)

You flashed the wrong SPI image to 3A SPI flash. ROCK Pi 4 SPI image can not work on 3A. Install the SPI image to 3A following the below step:

then dd the 3A Linux image to SSD when running from SD card, reboot and remove SD card, you are done.

I didn’t write Rock 4 SPI flash image to Rock 3. In fact I didn’t do anything related to SPI flash(it is in its default state)

Furthermore, as I know, green LED indicator is not related to SPI flash. In my case green LED is not working. Can you confirm that green LED should flash even if SPI flash is not configured properly?

Also, the image that I copied with dd command was image for Rock 3, not Rock 4.

This is probably same issue as I described here: UART no longer works after update

Mine board act like dead but it will start with no UART connection, eMMC and NVME, just SD card. I tried to clear SPI but still no luck getting UART back - it won’t start and no led. I have another rock 3A board and same set is ok on it. As far as I remember updating rockpi3a-rk-u-boot-latest or latest rk-kernel for 3A shows some firmware or SPI updating and problem started on next boot. I tried to clear SPI - but still I’m not sure if that was successful.

@jack - do we have any informations what firmwares can be updated on this board? Maybe it’s something else than SPI? I did not had so much time to reverse eng. those packages but more and more people experience those problems.

When I follow
RKDevTool says: “No Device Found”

I believe PMU unit of SoC is fried. In GPIO, Vdd5 has 0V, Vdd3.3 has 0.4V.
I don’t know what else can be checked to verify it.

Is there a chance that when device tried to boot from SSD, some settings during boot led to electrical inconsistencies between SSD and SoC which caused the issue?
Maybe Linux on SD card can deal with SSD, while when device boots without SD card, SPI flash cannot handle SSD.

It is my only explanation for now.

With right power adapter, cable and port mine is found on RKDevTools and it’s not when one of those is replaced to something else. Are You sure You tested whole set and it was working before? It’s just easy to make mistake here. In contrast to wiki on my computer it worked only with usb-c cable.

If something is fried usually You can easily smell that. I think something was updated with wrong version that stops boot process. As I said on my side UART, nvme or eMMC will do that and board is playing death - no reaction. Of course I cannot say I’m sure your is not damaged, just try more things to see if there is something that may worked before.

I’ll try to fix my board and compare everything to second rock3a I have. UART-less board makes everything much harder and I still would like to make it bootable from nvme.

Thank you for your reply.

Yes everything was working great. I was using Rock3 with SD card. Then attached SSD. Everything was still fine. I download image and then copied it to SSD as per instructions. Then shut down the system, removed the cable, removed SD card, and gave power back to see if it will boot from SSD, but since then device behaves dead: No power LED and the GPIO information that I provided you before. I am following official instructions to update SPI flash, but it says no device found(i have the yellow hat in place for the pins).

@jack Can you please confirm that even if bootloader is messed up, power should still flow to Vdd pins on GPIOs and that green light should flash?

On my both boards whatever I try green led is always on when power is connected (and it don’t flash).

Then I believe we have different issues. By flash I meant always on.

Some hardware issue is always possible. Of course You tested different cable and charger?

The issue appeared immediately after SSD boot attempt. I am using the same charging cable with Rock 4 without issues.

Since LED is powered from RK SoC Power Management Unit, I guess issue is relevant to that system.

  1. Please remove the eMMC module or uSD card on your 3A

  2. shortcut the 3P recovery header 1&2

  3. then use USB A to A cable connects your 3A to PC

  4. power on the board

PC should detect the device

   For Linux PC: lsusb shows: Bus 001 Device 049: ID 2207:350a Fuzhou Rockchip Electronics Company
   For macOS PC: lsusb shows: Bus 000 Device 004: ID 2207:350a Fuzhou Rockchip Electronics Co., Ltd. USB download gadget
   For Windows PC: Open RKDevTool and you would see "Found One LOADER Device".

If no device shown above, it might be a hardware issue.

Thank you for instructions. I tried it and nothing happens.

Can you please provide tips for troubleshooting HW?

If some minor component(such as capacitor) is burned I can replace it by myself.

The green LED doesn’t light and there is no Vdd on GPIO pins when I measure with multimeter.

I am a fan of Armbian. I think it may be more reliable when using Armbian to flash SPI.
Because flash SPI with USB cable in Windows OS is invalid.
(I did not learn English well.I’m a Chinese, so I write in Chinese.I have no choice.)

1.不建议通过USB数据线刷写SPI FLASH。因为不管是 Windows 还是 Linux 都可能会刷写失败。(尽管 rkdevtool 显示刷写成功,但实际上并没有刷写。)
2.建议直接在主机上跑Linux系统,直接对 SPI FLASH 进行刷写。(100%有效)

我一开始折腾 Rock Pi 4B+ 的 SPI 搞了很久。最终是通过 Armbian 的系统 刷写 Armbian 的 uboot 成功从 NVMe 启动。(网友说 Armbian 的 Uboot 兼容 Radxa 官方镜像,但我没有试过从 Armbian Uboot 启动 Radxa 镜像。)

参考教程(这是 rockpi 4B+ 的版本,你需要找 rockpi 3A 的文件替代。步骤基本差不多)

Radxa官方也采纳了前面这个网友的方法作为官方的参考教程(见 Method Three: Use the Armbian nand-sata-install script):


下面是关于 Rock3A 的一些资源地址。

Radxa Rock3A Armbian Uboot deb package download address:

Radxa Rock3A Armbian img download address:

Armbian 官方镜像 在 Linux kernel 5.x 之后 是包含 mali GPU 驱动的,所以你不需要担心GPU驱动问题。


  1. flash Armbian to SD card and insert to rock3a broad
  2. shortcut the 3P recovery header 1&2 (让SPI失效,CPU将不会从SPI读取bootloader。你不需要短接 Mashrom触点,因为你不是通过USB数据线刷写rock3a)
  3. power up rock3a and enter Armbian
  4. 跟着教程做