Rock 3a does not enter maskroom mode

I’m following this
I have no success at all.
Not on mac, linux or windows

Please remove sd card and emmc first, if you wanna boot rock3a to maskroom mode,
in v1.31 , you need to short these two pins ,

then plug the USB Male A to Mail A cable to ROCK 3A OTG port(the upper USB3 port), the other side to PC , and lastly power on the board


If you wanna boot rock3a to loader mode , you need to insert sd card or emmc, then the next step is the same as in maskroom mode


1 Like

thank you for replying.
still can’t boot into maskrom mode.
I came to test with another card but I have the same problem.


testing other USB ports.
outpout from dmesg


Please try to plug the USB power supply into the computer port.

thanks for replying, same behavior


Can anyone help me?, I have 30 rock 3a none enter maskroom mode

Try to follow these instructions to enter maskrom.

It uses the outer two pins (i think). You tell us if it worked.

thanks for answering, without success, did my rock 3a come with a defect?

No idea. you own 30 boards, it would be odd to have all boards with defects unless you did the wrong procedure on each board and damaged it.

BTW, why do you need maskrom anyway? You can flash eMMC with an adapter.

I don’t know what I’m doing wrong.
I need to boot with nvme for a project in my job.

Maybe you can describe (with pictures) your procedure step by step, so people can pinpoint what is wrong. Include the PC side.

Have tried with another USB cable?

use sudo before rkdevtool or adapt udev that user can access serial

put device before starting rkdevtool in bootrom mode

and use the right usb debug port

the short for the nand or emmc has to be short only for passing detection it is not a bridge

or use the windows rkdevtool there you can see when you connect a device in bootrom
dont forget to install the driver assistant before

and there is a uboot command to put the device in bootrom but that is not needed

put a switch, push button on the short pins remove sd and power and connect debug usb to pc
hold switch/button short
enable power
release switch/button

sudo ./rkdevtool uf /path/to/imgage


just ckeck the procedure

and ld wont do much the same information is given if you just start rkdevtool

all info given in above post you should get it working or your keeping doing something wrong

hello, thanks for replying, test on windows 7 and only unknown usb device appears

should the ROCK 3A OTG port be connected to the computer’s 3.0 port?

How do I get expert support?

well expert i dont know

and i dont even have that board

only thing i know that it just works with the above information

and with 13 boards your sure have one with a working bootrom :wink: so that could also not the problem

and with answers as windows 7 and no device is no information only that you doing something wrong

are you sure your using the right usb a <> a cable

and if rkdevtool is too difficult you could also just load a linux distro on a sd and boot that and then dd your image on the emmc/spi

or buy a sd <> mmc adapter even more less trouble

hello, thanks for replying, I’m using everything exactly the same as it is on the wiki, I tried it with linux but I get the same problem, I’m thinking that it may be low power from the usb ports, I’ll test with a usb hub to see

well you also have to connect power from only usb it wont work

and hubs makes a direct link between a pc and a device not better