ROCK 3 MODEL C: Boot from M.2 or eMMC?

I am interested the Rock 3 Model C. I see that it has both eMMC and M.2 slots. Is it possible to boot directly from eMMC or M.2 storage? Or does it only boot from the microSD card?

Yes, ROCK 3C can boot from SD card, eMMC directly. It also has an on board SPI flash, so you can boot from M.2 SSD without SD card or eMMC too. Currently we are working on booting from SPI to NVMe SSD, it should be released in two weeks.

I am also waiting for the ability to boot from NVME. Any news on this topic?

BTW, my new Rock3C does not have pre-soldered SPI Flash memory. Why?

I can solder the memory, but I need to know what type/model of compatible memory is, or at least what parameters are required (size, voltage, dual or quad SPI mode, etc.). Could you provide such info?

Cant wait.:smiley:

Please take a picture of your ROCK 3C board. We will check what’s going on.

For the SPI flash, you can use: GD25LQ128EWIGR, which is 16MB and voltage 1.8V, the footprint is WSON8. You can also use SOP8 footprint.

The new built image already supports NVMe booting:

Please have a try.

Photos of my board:

25LQ128EWIG is soldered. What now? How to install bootloader in new/empty SPI chip? Where to get the bootloader files for Rock3C from?

I would be very interested in that as well. Can you explain how to do this @jack? I tried different images I found online, also building the u-boot image myself. The serial console does not show any signs that it wants to boot from NVME.

Maybe @Stephen can help here?

Is this SPI flash already present on the Rock3C or do I need to install an additional 25LQ128EWIG SPI flash? Can you give an example?

I check this Link:
page 17 is GD25LQ128EWIGR
I need a method and tool for burning SPI flash, as well as a bootloader img file.

Need for burn SPI Flash.I updata this tool:

and I find ROCK 3A not 3C burn SPI by USB-OTG :

Next need bootloader img for burn, for start with M.2 Disk.
please release bootloader, we need try burn into Nor Flash.

Thank you.

this is my M.2 chip, can’t boot on. Serial Console no any print.

Any updates on this issue?

We are in the process of upgrading ROCK 3C to Rockchip 5.10 kernel, and once it is released, it will include the support to update SPI bootloader to boot from NVMe.

1 Like

Can we expect it to be released anytime soon? Because it would make a major difference. I’ve just received the 3C model (without eMMC storage), and thought it would boot from my NVMe (which i bought for this reason). Now it would be expensive to buy eMMC, and booting from MicroSD is slow.


is booting from M.2 NVME drive working?


I am also curious on the progression of this issue.

Was actually about to buy a couple of ROCK 3C boards, specifically because of the possibility to boot from an M.2 drive. Lucky to have found this discussion thread indicating that this actually does not work, and that radxa is not even trying to resolve the issue.

This was the only reason for considering the ROCK 3C over the Raspberry Pi 4B. Now that the Raspberry Pi supply issue has been resolved (selling locally at MSRP), guess that is the option to go for.

Too bad. Hopefully radxa gets its 5hit together. No point in designing and building a great concept board like the ROCK 3C only to not have its distinguishing features not work.

It still does not work!
Or am I doing something wrong? Here are the steps I tried:

  • Soldered the SPI flash IC onto board (W25Q128JWPIM in my case)
  • Download latest release (b36) from
  • Write b36 image onto sd-card and boot from it (‘uname -a’ shows kernel 5.10)
  • run ‘sudo rsetup’ -> System Maintenance -> Update SPI Bootloader
  • writing the bootloader takes about 10min
  • then shutdown, remove sd-card and start again

The output on the UART does not show any sign it wants to boot from nvme. No difference if nvme is installed or not.

I also tried to build u-boot myself from
No luck.

Can you give a detailed explanation on how to do this, since you said it would work with kernel 5.10? Thanks!

W25Q128JWPIM is not a supported SPI chip for this bootloader. We only tested with flash actually used on ROCK 3C.

Please try the following version:

DELETED as broken

Please try the following version:

Thats all showing on the UART. Not booting from sd-card or nvme.
Do you have another idea? Thanks!