RKDevTool issue - Get Capability Fail

I am trying to get openFyde running as in t/openfyde-chromium-os-fork-for-rock-5b/10963/25

Problem is that RKDevTool is showing “Found One MASKROM Device” but I can’t access the device via Advanced Function. On the first bootup it worked. Then the tool crashed randomly and after that I couldn’t get back access to the device. Every action is failing. I tried to reinstall the drivers, tried to use an older version of the tool - still the same.

I succeeded in flashing the fydeos for the eMMC of the Rock5B. And it’s running well.
My environment is below,
Image : https://github.com/openFyde/overlay-rock5b-openfyde/releases
PC : Windows11 with DriverAssitant_v5.11(My Win11 recognized v5.0 as unknown device, v5.11 is from https://rootmydevice.com/download-rockchip-driver-assistant/)
USB cable : A to C high quality cable with 10Gbps speed
Flash Tool : RKDevTool_v2.93
Good luck!

You can run OpenFyde on Rock 5B?
Do you have the Rock 5B 1.42 version?

I flashed OpenFyde but while using it / it freezes a lot and restarts a lot.

Can anyone confirm it is working on 5B ? What am I doing wrong?

Dont do advanced function.
For open fyde all u need is Download Image tab and select the image and the RKDevTool Emmc File (if u are using an emmc off course)
Then you go into the upgrade firmware (thats where the magic happens).
1st you load the firmware file there then you press upgrade.

My board version is 1.42.2022.08.29. It’s running stably and smoothly.
I never tell a lie, it’s just the rock5B.
At first , I tried NVMe SSD but it did not boot.

1 Like

AFAIR you need to boot loader first to get those to work
also some cables are problematic, but rock5 is working great with usb-c to usb-c cable on modern computers, they may provide just more power than usb-a

I’ve tried many things, but the way to boot reliably was as follows.

Target medium: eMMC
Environment:Windows 11 with Rockchip_DriverAssitant_v5.1.1 and USB A to C cable (Win10 with driver V5.0 is also ok.)
1, Remove all media.
2, Erase the SPI Nor Flash (https://wiki.radxa.com/Rock5/install/spi).
3, Attach the eMMC module.
4, Power on 5B with the maskrom mode(Connect Windows PC to the 5B USB-C port with USB A to C or C to C cable pushing the button neer the fan power supply).
5, Write the Fydeos to its flash memory using RKDevTool_v2.93 in Windows environment (Maskrom mode -> Update firmware).
6, Reboot.

1 Like

Thanks a lot.

Actually the RKDevTool crashed when downloading the firmware to the Rock 5B. Problem was that I forgot to reset the device in the RKDevTool before unplugging and attaching the eMMC. That’s it.

Just had the time to give it another try. Worked fine.

I tried RKDevTool v2.96 after that to verify that wasn’t the issue and it worked as well.