RK3566 Device stuck in MASKROM. Bricked

Attempting to flash Bootloader/Image to an RK3566 based board

Erasing flash worked fine, Device is detected in MASKROM mode in both Windows and Linux

When attempting to flash the image in Rkdevtool (i’ve tried every version from 2.8-2.96) we get “Download Boot Fail”.

I’ve tried every usb port on multiple PCs, different USB cables. rkdeveloptool in Linux and all the same thing. This device appears to be bricked.

This has happened to multiple devices (i’m not the only one with this issue, just reporting it for a handful of people), so any help would be greatly appreciated.

Hoping there is a pin to short or something of that nature that can allow me to flash this unit and un-brick it. Pictures of the board attached.



Click ResetDevice and download again. After downloding the firmware, I also get Download boot fail if I click Download for the second time, a reset will fix it.

Tried again to confirm. No response to ResetDevice

Two possibilities:

  1. There’s a new version of the bootloader.bin that doesn’t work (as with Rock Pi S - the one linked in instructions is broken; you have to find an older version in the forums)

  2. If the Flash memory is anything like the Rock Pi S, it’s likely the flash IC is shot. I’ve seen more cases than I can count on two hands of the flash IC giving out and the rest of the pi being perfectly fine.

If this is the case:

  • The SoC will still enumerate as a USB device
  • The board often will have no trouble booting from an SD card (flash tends to fail Hi-Z)
  • Probing the flash clock will illustrate it’s still present
  • Probing flash data lines on device reset (w/o SD installed), all bits will stay static

Hope this saves you pulling out as much hair as I did.

Any recommendations for testing?

So far the unit does not respond to any command we throw at it. I’m attempting SD boot but does not seem to be working

Hi @ sic, I have the same exact board G285 rk3566 2GB ram :wink:
I was able to load rk356x_spl_loader_ddr1056_v1.10.111.bin with rkdeveloptool from my laptop running Linux (PopOS).
I even was able to write LBA with new image, an image made for Radxa CM3 IO (radxa-cm3-io_debian_bullseye_cli_b27.img), thinking rockchip boards would be unbrickable… and I have made previously a backup of the whole LBA/emmc.

WHAT A MISTAKE !!! Don’t do it!

Now my board doesn’t boot, all LEDs are off, the USB-OTG port doesn’t respond anymore, no maskrom, no loader, no nothing, like a dead port (nothing in dmesg nor lsusb). So no ability to run rkdeveloptool anymore. No response to recovery/reset/bt reset buttons. And worse: the metal plate (that covers the SoC, emmc and RAM), runs quickly extremely hot, like a toaster.
Edit: after removing the metal plate, it is the rockchip SoC that runs hot as hell.

My board is now really bricked, and way more than yours :confused: