Rfcomm failures in ubuntu Server Image and Debian desktop image


Both Images:
rfcomm does not work properly. In debian, rfcomm bind returns tty support not available. Therefore, I cannot connect to a bt serial Port.
On ubuntu, it doesn‘t even find hci0. The bluetooth Adapter is Not detected. Tried various rebuilds of the kernel with different bluetooth options set, but it remains the same.
Anyone any idea?


What does
systemctl status bluetooth

Also, read this


This is the Output on debian:


Well, than we need to ping developers… For now try Armbian and start_bt.sh


I tried with armbian. The problem ist exactly the same as in debian. After starting bluetooth, the bt serial port can be paired but not connected. Trying manually with rfcomm bind yields RFCOMM TTY support not available.

I don‘t know what to try next. On the raspberry pi the bt serial port connects without any Problem. I wanted the rockpi because of usb3. Seems like it is useless for me,though…


Well, before this. Try this armbian


Doesn‘t work einher. Doesn‘t even find the bt Adapter.


Seems like Kernel module btusb is missing. Ideas?