Read Network mac address failed


is it possible to set a hardcoded mac address and not a random one?


Kernel Log:

[ 6.832965] rk_gmac-dwmac ff4e0000.ethernet: rk_get_eth_addr: rk_vendor_read eth mac address failed (-1)
[ 6.833080] rk_gmac-dwmac ff4e0000.ethernet: rk_get_eth_addr: generate random eth mac address: 7e:34:59:63:28:f3
[ 6.833100] rk_gmac-dwmac ff4e0000.ethernet: rk_get_eth_addr: rk_vendor_write eth mac address failed (-1)
[ 6.833138] rk_gmac-dwmac ff4e0000.ethernet: rk_get_eth_addr: mac address:

I have the same issue. (see dmesg output here:

Where is the MAC address supposed to be stored? The SPI flash is not populated on the board.
I can find 4 calls to “rk_vendor_register” in the kernel source:

The output from dmesg has two lines with “vendor storage”:

line 336: [ 0.466999] flash vendor storage:20170308 ret = -1
-> drivers/soc/rockchip/flash_vendor_storage.c#L306
-> _flash_read was not set…

line 431: [ 3.472590] vendor storage:20160801 ret = -1
-> I can’t find that in the kernel. The line was probably changed since then.

That’s what I got right now.

Thanks, but I don’t think that is related.
This issue is with the ethernet mac not being able to read or persist its mac address due to not initialized callbacks (see kernel output). Usual/planned address randomization is probably not going to end in kernel errors.

It’s the same with the wlan mac address. It’s a kernel problem and not a wrong network manager option.