Raspberry Pi OS on Rock3


Has anyone had tried running Raspberry Pi OS on the CM3 and if so did you have success? I have tried the both full desktop versions and lite versions of both the 32-bit and 64-bit images an none of them boot. I’m assuming the device tree needs to be totally changed for the OS to run but is that all would need to be changed or is this not at all possible?
I have the CM mounted on a Raspberry Pi CM4 IO Board.

Raspberry Pi OS is just debian linux customized just for their hardware, if You need something similar and don’t want to do all things yourself then search for anything that is also based on debian, then just add things You need - maybe desktop, maybe some apps or libs.

Right, thing is I have a camera that I would like to use and the only way to use it is to use a driver that will only work with a specific version the Raspberry Pi kernel.

since neither the drivers are inside radxa kernels, nor the overlays, you simply can’t use them

If You don’t feel strong enough to get this thing supported (with own kernel) then just sell it and replace to something that should work. Radxa 4k camera is $25. That’s not much for good quality cam.