❌ Radxa Zero - Dualboot Android eMMC / Linux SD - *NOT* possible

Dear forum, dear Radxa Team, I would like to ask from your experience, if it would be possible to install Android on the eMMC and possibly do dual boot with Linux, installed on an SD card.
This without having to delete Android from the eMMC every time.

To clarify:

  • SD card NOT inserted: boot Android from eMMC
  • SD card inserted: boot Linux
    Would I need to flash a particular file to achieve this? u-boot.bin? u-boot.bin.sd.bin?

Eventually would it be possible to do it the other way around? Linux on eMMC and boot Android from SD?


1 Like

This is current booting logic, we added Linux support in the Android bootloader, but only for distributions like Armbian or CoreELEC, which uses boot.scr to loader kernel in SD card. For exlinux booting in SD card, it’s not supported.

@jack Thank you for the information.
Before I posted on the forum, I had tried but without success.

  • I’ve installed your version of Android, flashing to the eMMC first bootloader.img, and then Android itself.
  • Using the software Balena Etcher I installed on the SD card the image you provided on GitHub Armbian_22.08.0-trunk_Radxa-zero_focal_current_5.10.134_xfce_desktop.img.xz (after decompressing it).
  • I finally inserted the SD card, and connected the USB power cable to the Radxa Zero.

Android was booted instead of Armbian.
What did I do wrong?
Should I have flashed some β€œ.bin” files to the SD memory card, before flashing Armbian?

From (older) post on the forum I get the feeling that booting from SD while Android is on the eMMC is not possible. eg Tried the 20220616 ubuntu focal img - got Android

The image provided on the GitHub is specifically listed as unofficial build. Radxa Zero is officially supported by Armbian so please use their image.

This is correct. Android uses a different bootloader currently and it will load Android from eMMC.

Thank you @RadxaYuntian.
So, basically the statement of @jack about booting Armbian from SD Card while Android is on the eMMC is incorrect.

I’m asking our Android engineer for confirmation about that booloader change.