Radxa x2l issue with HDMI

I have several x2L boards and i have issue with hdmi connection to 10.1 inch screen and realtek controller rtd2660h.
The screen is black without signal till OS desktop starts, than i get signal and screen is working.
So i cannot access bios or any os setup. Same screen works with other computers without any problems.
Radxa x2l boards are also working with other monitors.

So i think there’s some compatibility issues between those two and screen doesn’t get signal to switch on in bios or terminal.

Does someone have a tip? I have tried different bios settings without any luck.

The X2L has 2 hdmi ports, have you tried change the hdmi ports? Or can you connect only one hdmi port at startup and leave the other port unattached for hdmi devices to display?
Or temporarily disconnect the SSD or other boot device and see if it can be displayed under UEFI shell?

I have tried all this combinations and also all other possible combination but in all cases display is not starting till desktop starts.
Only one combination works: connect working monitor than start board up, after i see UEFI shell then disconnect hdmi cable and connect 10 inch screen. In this case it’s till next reboot

This looks like a compatibility issue since other screen works fine. we are works fine with an 11.6" hdmi screen (1080p resolution).
Maybe another HDMI cable help?

day 1 with X2L

TL;DR …
(1) I think I have the same problem described by OP.
(2) I think I have identified actually TWO HDMI-related problems.

By way of background: I think this is my first-ever SBC.

Lots of careful reading around as many sources as I could get (including a lot of posts in this forum), before applying power first time. I haven’t yet installed the heat sink, but the wifi/bluetooth module and an Inland NVMe 256G SSD all in place, and no magic smoke has come out (always a good sign). Oh yeah, and the CMOS battery.

The desired monitor a 10.1" touch screen (aprotii, 1280x800) which I have confirmed to work (with an HDMI cable) on two different desktop boxes (one win10, one Linux Mint). Used known working cable to attach to the X2L. Monitor is powered via a wall wart (not trying to pull power thru the X2L USB-A port). Leaving the touch function unconnected for now, but I’ve confirmed it works on the Mint box.

Several attempts to boot: the behavior of the power LED (long red the first time, then steady white) seemed to be doing what it was supposed to, but nothing showed up on the screen.

Moved the assembly over to my desk, reassigned one of my daily driver’s monitors to the X2L, and tried again. Lo and behold, there’s the boot screen, and I can navigate around there more or less as shown in the instructions. Got me a fresh Debian 12 on a new thumb drive, and was able to fake my way thru installing the OS.

So all that is done, and it’s time to boot the OS for the first time. I’m still on the “regular” desktop monitor. It starts to clearly display a boot sequence (no screen shots, sorry), then the monitor flashes a complaint that the signal has gone out of spec (says I need to change settings to 1920 x 1080 60Hz), and the monitor times out and goes to sleep.

On a hunch, after having read this thread, I disassemble everything, move it back to my workbench, put it all together with the 10.1" aprotii monitor (same setup as before). The only thing different now is that I have an OS on the SSD.

Power up … it’s blank for a while, then … lo and behold, I get a login prompt! I can log in to the user account I established, fake my way around with cd and ls, then properly log out. This is repeatable. No display until the login prompt shows up.

SUMMARY:

(1) one monitor doesn’t work until the boot sequence is done.
(2) the other monitor works at the start, then the signal goes out of its range.

So, what words do I need to look up in order to understand this problem? Is there some kind of config file or BIOS setting that I am missing? Is there some magic about HDMI that maybe I should know?

thanks all

Thanks for your detail information
We have some possible directions for these 2 phenomena

  1. for 10.1’ touch screen, Is the screen not displaying because the monitor response time is longer than regular HDMI monitor?
  2. The model of your desktop monitor? And it is only the tips or impact on use? We checked on some 4K@60Hz monitor w/o problem

BTW, the Intel website say the J4125 SPEC support HDMI 4K@30Hz. https://ark.intel.com/content/www/cn/zh/ark/products/197305/intel-celeron-processor-j4125-4m-cache-up-to-2-70-ghz.html

Hi, thank you for your reply.

The response time of the 10.1" touch screen is claimed to be 3-5 ms.
and the refresh rate is said to be 60Hz

The desktop monitor is several years old, might be HP, definitely not 4k.
Desktop monitor settings: 1920x1080 - 60Hz.

I’m not sure how to interpret “only the tips or impact on use”

thanks