Radxa Rock 5B: reboot, what's the reason?

Hi all,
after being able to install operating system and placed the Rock 5b in metal case, I was trying to finish my system setup: adding programs, upgrading software. At this point I noticed that every time I’m doing something vaguely intense (git clone, apt upgrade), the system has a spontaneous reboot, right after few seconds when this intense part begins (resolving deltas for git, or compiling kernel modules).

How can I find out possible causes?

I give you also a few more details about it:

  • I’m using radxa rock 5b 16gb ram
  • the operating system is inside an emmc card
  • I’m using official power supply
  • I’m using official metal case

Please let me know if you need further information. Thank you in advance.

Have a slow reading on this and I hope it answers your question: https://github.com/ThomasKaiser/Knowledge/blob/master/articles/Quick_Preview_of_ROCK_5B.md

do you mean all document or some part in particular? I suspect I added too much thermal compound, this could be a reason for overheating? I believed that fan was compatible with metal case, so first I assembled it, after realizing I needed to chose between case and fan, so I removed fan and added also case thermal compound.

UPDATE: thanks for passing this information but I would like to have a way to detect a problem (maybe an overheating), it is a huge document and talks of a lot of things, I read all final notes summary to find something similar to what is my problem but I didn’t find anything, or probably I’m just not understanding too much technical concerns and I’m not able to recognize a reported issue is matching mine.
Is there any standard troubleshooting procedure or something I should try to understand what’s happening?

UPDATE2: I understood how to grab a full system log regarding previous boot, with sudo journalctl -b -1, so I saved it to file, it is 162KB long 1681 line longs so I attach instead of pasting directly, there are a lot of warnings and errors but I cannot understand which one I can safely ignore and which others are related with reboot.journal.zip (25.5 KB)

I forgot to say that I also tried to reduce memory frequency, doing this:
echo 1560000000 | sudo tee /sys/class/devfreq/dmc/max_freq

the issue was freezing during rsync, by the way nothing changed with this.

download @tkaiser sbcbench and run several tests, it will give you some insights about configuration and You will have option to heat up the board, this may be good test case.
Repeat same on different system, this may be somehow related to particular kernel.
I got such issues with some nvme and small power adapters, never with emmc, but this always worth to check, dumb 12V with reasonable amperage should always be safe option for power issues.

thanks dominik for the hint, the problem is that script makes use of apt-get to install tools, and I have it in a inconsistent state, due to the fact that failed compiling kernel modules in last upgrade and if I try dpkg configure -a to fix it, I get a reboot.

I will find a way to unlock the situation.

No way, I was able to unlock apt by moving away for a bit files in /var/lib/dpkg/updates I downloaded and used sbc-bench from here : https://github.com/ThomasKaiser/sbc-bench , I was able to run with -c option and also -r (review), I adjusted /cpufreq/ondemand/io_is_busy because I had an ondemand cpu overnor, as well as other settings I found with link provided by sbc-bench (full fix I run at startup):
echo “starting tweak”
CPUFreqPolicies=($(ls -d ${prefix}/cpufreq/policy? | sed ‘s/freq/policy//’))
if [ ${#CPUFreqPolicies[@]} -eq 1 -a -d “${prefix}/cpufreq” ]; then
# if there’s just a single cpufreq policy ondemand sysfs entries differ
for i in ${CPUFreqPolicies[@]}; do
affected_cpu=$(tr -d -c ‘[:digit:]’ <<< ${i})
echo ondemand >${prefix}/cpu${affected_cpu:-0}/cpufreq/scaling_governor
echo 1 >${i}/cpufreq/ondemand/io_is_busy
echo 25 >${i}/cpufreq/ondemand/up_threshold
echo 10 >${i}/cpufreq/ondemand/sampling_down_factor
echo 200000 >${i}/cpufreq/ondemand/sampling_rate
echo “ending tweak”

by the way the issue is still there and I’m not able to run sbc-bench with option -t because cpuminer cannot be executed, I also downloaded it from repository https://github.com/tkinjo1985/cpuminer-multi?tab=readme-ov-file and build.
output sbc-bench -r
$ sudo ./sbc-bench.sh -t
sbc-bench v0.9.67

Installing needed tools: distro packages already installed..../sbc-bench.sh: line 3286: : No such file or directory
./sbc-bench.sh: line 3290: : No such file or directory
./sbc-bench.sh: line 3291: : No such file or directory
./sbc-bench.sh: line 3309: : No such file or directory
./sbc-bench.sh: line 3381: : No such file or directory
./sbc-bench.sh: line 3388: : No such file or directory

Thermal efficiency test using /sys/devices/virtual/thermal/thermal_zone0/temp

Installing needed tools. This may take some time...WARNING: Not able to execute cpuminer. Aborting.

output cpuminer
$ cpuminer-multi/cpuminer
** cpuminer-multi 1.3.3 by tpruvot@github **
BTC donation address: 1FhDPLPpw18X4srecguG3MxJYe4a1JsZnd (tpruvot)

[2024-06-24 20:14:09] Starting Stratum on stratum+tcp://yiimp.ccminer.org:4252
[2024-06-24 20:14:09] 8 miner threads started, using 'decred' algorithm.
[2024-06-24 20:14:09] Stratum connection failed: Failed to connect to yiimp.ccminer.org port 4252: Connection refused
[2024-06-24 20:14:09] ...retry after 10 seconds
^C[2024-06-24 20:14:12] SIGINT received, exiting

There is nothing to do, When it rains, it pours, I’m tempted to give up, I already faced too much issues since now, I’m doomed with this radxa sbc. Anyway I would like to try something more if there is, in order to fix it, when options are really finished I can give up.

If You have any spare sd card just boot fresh system to check if its something about system or hardware. Just try to reproduce this with something different and incrementally add Your customisations.
Most of instability comes from kernel and simple mistakes and this is really easy to diagnose. sbc-bench is great tool for tests and it will probably hit most of hardware related issues if there are any.

I agree with you that sbc-bench is a great tool, what I’m saying is that I wanted to do a thermal check but for some reason, even though I compiled cpuprime, it doesn’t seem to be detecting it or working properly…

I thank you for the suggestions, since now I’m using rock official image, Would another OS like Armbian potentially be more stable? I thought that using official image would have provided me a stable and painless experience. I’d like to try things but I would also like to try something that is the best for most people using my same sbc, so I ask you an advice on which image I should try to have a stable situation. I think if I get repeatedly reboots every time cpu starts doing something also with that operating system, might be a defective hardware problem and if so, I probably need a replacement from who sold me it.

Thanks everyone for your help! I’ve decided to contact the shop where I purchased the Radxa board. I experienced unexpected system reboots while extracting a 1.9GB RAR file (at the very beginning) using Armbian server version 6.1.

I’m requesting technical assistance to the shop to resolve the issue or a replacement for the board.
If for some reason I realize that this is not a faulty board but this is normal behavior of radxa board, that you need to tune up to reach a bit of stability then it appears I may have chosen the wrong product for my needs. I can understand other persons point of view and interests in tuning and optimize but I bought an sbc and not a pc to assemble because I wanted something working out of the box.

I’ve only had this board since the 17th of this month, and unfortunately, I’ve already experienced a significant level of frustration, I hope I was just unlucky and I received a faulty product.

1 Like

I would suggest carefully read this topic.


1 Like

They likely won’t have any idea about this. These are niche products and only the users (who frequent forums etc) will know the issues. Also, the board and software developers, but they rarely interact with us normies.

I have had a similar issue, although it involved running a compute intensive application. It was suggested by Radxa staff that it was a power issue. It may be that even the official power supply might not be up to the task of running the system in a stable fashion.

1 Like

I already did, if you can see there is also a post from me that says I also tried changing memory max frequency without any luck

1 Like

What convinced me to purchase this product was this video review: https://www.youtube.com/watch?v=w85QTDPp-4Q , so I expected to be easy-peasy to setup, and stable to use (in the video there are also some intense benchmarks proving this), so I still think maybe is my board or one of its accessories be faulty.

I’m contacting who sold me this product and mine accessories just because they can replace me faulty parts or I can decide to give back everything and have money back, I don’t expect some specialized tech support, I asked for it also to okdo (which sells and manage radxa products in my part of planet) without any response.

If with a product replacement, I’m not getting this work, I will give up, because it means that this product is not for me.

It is bad to make comparison with boards/systems of other brands, but this was mine experience so far:

  • 3 different raspberry pi 4b : flashed the sdcard, worked out of the box and without issues with 3 different OS images and cases
  • 1 zimaboard (I needed an x86 one): comes with its own operating system installed, I only extended its storage with a sata ssd, worked of of the box without issues
  • 1 beelink minipc, came with windows 11, I installed ubuntu, worked flawlessly
  • radxa rock 5b: issues understanding what to buy for a complete solution (nothing is included, neither storage and power supply and there are not official kits), issues about understanding what to install and how, no responses by manufacturer, continuously reboots.

I’m not asking to make an exotic feature or component to work in a specific way, I just want to use my board as an headless server, having it running without sudden reboots I think is the bare minimum.

I really want to understand if this is caused by a faulty board or accessory, or if it is the normal behavior, in second case this is unacceptable for me.

Then you can check the output of the SPL bootloader via UART (if you have written a debug version) to see if your board is booting this SPL.

You can tryout my archlinuxarm image (w.i.p.): It runs a headless server just fine

ftp://ftp.woudstra.mywire.org/images (also http(s) available)

Or even better use my build script buildRKarch found on github to build an image on SD-card.


When logged on, ( or uart or monitor+keyboard) you can:

sudo rockchip-toolbox --uboot@spi

To write the uboot+spl I build to spi.

Don’t worry about this, we all do comparisons on each models and features.

Raspberry is much more popular board with large community so many things are just easier there for non advanced users who expect to just flash something and run ready out of box software. Large user base helps to find bugs easier, maintain releases and get reasonable amount of feedback.
On the other hand pi was always basic hardware without too many features and cutting edge specification at quite high price.

x86 is different story.
still bit more expensive, and much easier to maintain because only two big manufacturers responsible for CPUs,

Everything is in docs,
there are many official accessories, tested and working, just browse radxa.com site,
Also it’s not that hard to troubleshoot if You hit some of issues, same thing applies to raspberry, where You can easily get same effect with not dedicated power source,
You need to have minimal knowledge about basics to be able to describe problem.

BTW: with new releases there will be something like BIOS/installer burned on board to start, test, install recommended images. This will not solve any hardware related issue (or lack of power), but may be helpful for people like You.

This does not sound like normal behaviour at all, but you’ll be sure only when you use UART.

For me, troubleshooting Radxa issues is much easier than raspberry pi issues. They have a forum but so many topics with problems are just left without an answer. If you have something specific that doesn’t work, you are often on your own. Here someone at least replies.

The Raspberry Pi Foundation has an OS that works but is also not very good and due to this (+ youtube influences) they convinced people to always start with official distros. And those are most often even worse.

If you’re buying a PC, you wouldn’t use a system that the PC manufacturer made (unless it’s Apple), you would install Windows or Linux or whatever. It’s the same with SBCs. First party systems are made just to start using the board, not necessarily for general usage as many things that run on more “standardised” OSes, like vanilla debian for example, won’t run very well on them.

This is very good advice. UART is just standard way to get all messages from boot and diagnose many errors. Unfortunately most expect to plug n monitor and see nice information instead of that. :frowning:

thank you for your advices, I discovered that there is not a specific uart cable for radxa, so I’m trying, on same website where I bought mine board to find out something that may work in my case, I’m pointing to this particular site because is the only one that sells okdo/radxa products in my country, and expecially for a cable you may imagine that for example a cable ship from China or USA may cost me 2 or 3 times more and may take also a month to arrive.

So I would like to ask you, if you want, and if you can help me to understand this from documentation https://docs.radxa.com/en/rock5/rock5b/low-level-dev/serial:

The Flowing text uses a serial cable based on CH340.

does it mean that if I choose a model based on CH340, whichever is the brand, it shoud be fine? is it a mistake and they wanted to write “The Following text …” so the rest of the guide is using this cable?

I found on website of my re-seller these two products:

I know it is in italian but on top there should be attached a pdf with datasheet and I will thank you if you could have a look and tell me something about them or let me understand better what should I search for.

Menwhile, since the re-seller didn’t answer yet, I’m going to do other things you suggested me.