Radxa Failed to Boot

My device is experiencing a very strange issue. It was working perfectly fine before I went to sleep yesterday, but today, after plugging it in again, it shows no response. The power LED is on, indicating that it is receiving power, but there is no HDMI output on the screen. My device is a version that doesn’t have built-in storage, and it requires booting the system from a TF card.

I have already tried the following troubleshooting steps without success:

  1. Reburning the image using Rufus.
  2. Changing the SD card and burning the image again using Rufus.

Despite trying these methods, when I power on the device, there is still no HDMI output, and the only indication of it being active is the illuminated LED.

I attempted to connect the device using USB BOOT, and I found that GX-CHIP appeared normally on my computer.

The entire situation is quite puzzling as there were no issues before the short period of normal operation before shutting down. There were no accidental drops or impacts either.

I’m wondering if any of you have encountered a similar situation and how you resolved it. Your help would be greatly appreciated.

Thank you all in advance.

This will tell you what’s going on: https://wiki.radxa.com/Zero/dev/serial-console