Radxa burning like hell


I wanted to create a GameBoyZero using a Radxa.

However, I did something and now it is heating like crazy when I power it (it takes like 2-3 seconds for it to be unbearable hot if I touch it, so I cut the power).

I think it’s broken.

What I did:

  • I wired my gameboy components, but for now only the power part (usb-c adapter, a switch, a power booster set up to 5.3V, and then the screen and the radxa)
  • when powering the radxa directly (usb cable to the radxa), the screen worked and I could play games
  • but when powering using my usb-c adapter, everything seemed to work (led lighting on radxa, screen showing EmuElec boot logo), and then it seemed to reset (and enter a loop: booting up, then reset before I could see EmuElec dashboard)
  • therefore, while powered up, I (slightly) increased the power booster output voltage, but then everything went black and the radxa began heating like crazy
  • I stopped everything, and tried the radxa alone using a standard usb-c wall plug (which seems to deliver only like 4.7V or something, btw) but the radxa did not boot and heated like crazy

I wonder:

  1. is my radxa dead? (I think so)
  2. what caused it to die? Is it because I gave it like 5.5V?
  3. can I repair it?
  4. before it died, why would the system reboot-loop? If I only wired the screen and not the radxa, the screen itself did not loop/reset

Thank you kindly for any input!



  1. It seems so.
  2. Yes. 5.5V exceeds the voltage of some components.
  3. We don’t know exactly what component burned out. So you can’t easily fix it.
  4. I have no idea, but from your description, it looks like it has something to do with adapters.

Hi @setq

Thank you kindly for the reply.

Ok the tutorial that I followed advised to set 5.3V. I thought that if it looped was because it did not have enough voltage to power both the screen and the Radxa properly. But I reckon I was mistaken.

What do you mean by adapters? Do you mean the power booster was not strong enough? Or my usb-c input was not good enough?

The screen was hooked to the Radxa using HDMI (because I had another screen that required a tv-out on the SBC but the Radxa does not have one).

Thank you again!


Thank you kindly!

Here’s what I understand:

  • powering the board directly — work
  • powering using your usb-c adapter — not work

Is that right? But I don’t quite understand the difference between the two cases.

Yes you understood right!

My schema is:
usb-c module ==> switch ==> power booster (5.3V) ==> screen + radxa

Using this, the screen and radxa would both power on (I could see the EmuElec boot logo), but after a few seconds, the power would somehow reset (both screen and radxa, apparently), and start again.

When powering only the screen, no issue.

Alternatively, when using directly my power outlet (4.4V, from what I can read on my multimeter) to power the Radxa (the screen is powered using the radxa gpio), everything worked.

Maybe 5.3V was already too much for Radxa? The tutorial said that it was better to have more than 5V. However, my power outlet only supplies 4.4V and it worked :-/

EDIT: I found out that the usb-c module that I was using (TP4057) only supports 500mA which I think is too low for allowing the Radxa to work properly, which causes the reset.

I recently ordered TP4056 and ZY12PDN which support respectively 1A and 5A (if I’m not mistaken). I think I will used the latter (ZY) so that it can support a heavier load. But at 12$ for one (versus 1$ for the TP), it is quite expensive… :confused:

Looks like too low a current is what’s causing the reboot.