Quectel EC25-A Mini Pcie 4g

i have installed the EC25-A module to the riser card, but, it doesnt get picked up on ubuntu server, i have tried to install the quectel drivers, which say they have installed. but it cannot been seen.

am i missing something simple here ? any advice would be greatly appreciated.


you can refer to this page

thanks for the response Peter.

i am installing the Quectel EC25-A mini PCIe modem. i have received the latest drivers etc from my supplier, i had to modify them slightly, as they were not pointing to the arm64 folder, they all appeared to install correctly, but i cannot seem to see the device.

i am using the riser card, and a adapter plate from m.2 to mini pcie.

any thoughts ?

please excute the command sudo lspci to see whether the device is recognized by rock, if yes, please
share more info, such as the driver files, the porting steps, the kernel log after you installed the driver on rock

no, i have tried that command previously, i have also installed qmicli, but it cannot be recognised. it is very strange.