Problem send DTMF command

Hi everyone,

My name is Yann, I am a french electronic student who is working this summer in a lift factory. I am using a SIM7600E-H shield GSM device with a Raspberry Pi 3. I encounter some problem with some AT command in order to generate DTMF Tones. The problem is :

I call my mobile with the ATD command from the Raspberry controller, I use an file with Python for sending AT command, everything works

I want to pass some DTMF Tones using AT+VTS command during the call, the AT+VTS command works sometimes, says OK but can’t hear any tones but most of the time it doesn’t work.

When I want to change the beep tone with the AT+VTD, it says OK and after the AT+VTS commands doesn’t work always says “ERROR”

Another fact is that when I want to use the AT+VTS with curly bracketed group {} or with bracketed group [] it always shows an “ERROR”

Now when I call from my mobile to my device (Pi + SIM), I automatically answer with the ATS0=1 command, it works.

I can modify the beep tone duration to 100 : AT+VTD=100, and when I use for example the AT+VTS=1 I can hear the tone and it says OK, but not everytime, some AT+VTS number such as 3 doesn’t work, that’s seem better but now when I want again to use the {} [] group still doesn’t work.

I tried the AT+CLDTMF generator but always ERROR.

Thank you in advance for your support, I would like to send DTMF Tones when “I” call my mobile from the Sim/Pi device and hear the tones when I put AT+VTS command, maybe it’s an AT command that I forgot to setup my call to clearly send and hear the DTMF Tones.

Thanks for everything