Power issue on Rock 4SE with quad SATA hat?


I wanted to make a small NAS with the 4 SE and the sata hat (https://dk.rs-online.com/web/p/rock-sbc-add-ons/2565003).

As soon as i try to mount a filesystem in OMV i get a weird clicking from one of the drives. I am running a RAID5 configuration. I have not tried other types of RAID arrays.

I have tried reinstalling the whole thing, and stress testing the devices 1 by 1 on a different PC without any issues. But after the reinstall it does the same thing.

Others have suggested a faulty HAT, or maybe even a power issue so i want to look into that one first.

As per the documentation a 12V/4A should be sufficient for the hat. I have a 12V/6A PSU connected to the barrel jack. But i noticed that the power requirements of the drives are 5V/0.85A - is that an issue? Are they being over volted or can the chips on the HAT handle that conversion?
Would i be better off finding a high A 5V USBC and powering it over the rock and GPIO pins?

Any help/insight is greatly appreciated!

Can You please post photo of Your setup?

Indeed I got such issue when I connected Rock4 with just usb-c and hat with four drives, there was not enough power for whole thing. Then I found 5A/12V and connected that one to HAT - this one was ok, no clicking noise.

12V/6A should be ok, but it may be faulty unit, get multimeter and try to measure voltages. Maybe You can find different ac adapter to test it.
Are there any errors in dmesg? QUAD sata HAT has option to use hardware RAID (but not 5) and it’s way better than other options, don’t use SoC that much. There are some problems with UAS mode as well as SMART configuration, those are related to JMS561 firmware, and You will get information about those in logs for sure.

Thanks for the reply!

See attached photo. *Note that the connection between the HAT and the rock is the IPEX connecter on the opposite side of the USB and ethernet ports.
I dont have a mulitmeter, but this might be a good excuse to get one.
Ill have to look in my storage for another unit able to supply 12V/4A or above.

I havent checked those logs. But as far as i can tell from OMV logs there are no issues.

I have tried to change a few settings in the OMV drive settings related to power management - maybe that helps too.

In terms of hardware/software raid the main reason to use hardware over software is performance? I havent noticed either RAM or CPU being overused in the software raid configuration.


We should be able to get some information from the command dmesg

OMV can show You syslog, but it will not notify You about any issue there,
Also it’s rather not much comfortable to view those via web panel, I’m always just enabling ssh and view everything from command line,

I don’t expect any real change there. If there is hardware (power) issue then You need to find root of the problem. Usually all power settings help to tweak several things, usually regarding power save modes.

Stability was my main concern there.
JMB chips used in this HAT have some problems with certain drives and configuration. Any issue with RAID5 leads to constant rebuilding everything. You may be more lucky, have better disks or same bugs are already fixed, when I tried to setup that HW RAID was the only stable option for me. More CPU for everything else is just extra bonus. Since I switched to 2x HW RAID1 it’s very stable, no problems for more than year.

I actually managed to fix the issue with the advanced power management.

I confirmed the PSU delivers 12v - and with a WiFi smart plug I confirmed that the power consumption doesn’t go over what the PSU can supply.

I think something with the standby settings was keeping the drives in a boot loop or something.

Can You please say something more about that advanced power management and how that fixes this issue?


I had it configured to 127 - Intermediate power usage with standby

After disabling that i have had no issues.
I dont know exactly how it can cause that clicking, but maybe the disks kept trying to go into standby every few minutes and then it rebooted them immediatly?