Please help. I can't boot it from SD

Greetings to all!
I ask for help from experts.
The situation is as follows.
Got a new 3A. I power it from a 45W power supply (I bought it together with 3A).
The device is empty in terms of load.
There is no EMMC, no wifi, no BT.
Only USB keyboard and SD card.

I’m using a regular micro SDHC IU1 class 10.
Updated info
I used “balenaEtcher” to burn Manjaro to SD

After I turn on the power the result is always the same.

First, the green LED lights up. After a few seconds, the blue diode starts flashing.
The flashing mode is like this. Two flickers, then a pause. And so on in an infinite loop.

At the same time, there is nothing on the hdmi output.
I changed two hdmi cables. No signal.

I connected the TTL-USB adapter to the UART port, as described in the WIKI.
I used different transfer rate settings, both 15200 and 150000, as indicated.
I tried to connect the signal wires TX, RX in any way.
The result is the same. There is no data transfer from UART.

What did I miss?

Hi, DenisKa.
I’m not an expert but I’ve used the Rock 3A for four months. I will send my comments due to weekend.
From my experience for 4 months, troubles seems to come from power supplies, uSD cards include flashing, and board failures. In addition, some debugging tools (TTL-USB serial cable) are not suitable for this application due to lack of baud rate or different TX/RX voltage.

Regarding serial debugging, Rock 3A is using 1.5Mbps (1500000 bps) , not 150000. May be it’s a typing error.
In my case, serial output starts before blue led lits, for example, power on, after 3 seconds serial output starts and another 2 seconds later blue led starts to blink at interval of one second.

Therefore, in your case, I think there is possibility of serial output around the blue led blinking. So please check baud rate setting and specs for TTL-USB serial cable.
Good luck!

Hi, yoshis
Thank you for your help.
Can I clarify some more things?
Do I understand correctly that the UART starts working only after a successful kernel boot.
Thus, if the SD is incompatible, then the kernel will not boot, and in this case I will not see outgoing traffic from the UART. Is that right?

No you should be able to see logs as soon as power on the device with a bootable image on either sdcard or emmc.
If the drive is not bootable then there won’t be any logs on uart.

Hi, DenisKa.
As spikerguy wrote, after power on, green led lights up, then UART starts, and 4 or 5 seconds later blue led blinks at interval one second and the kernel starts. In my case, if uSD card is incompatible the blue led does not light up.
So, since your blue led lights up and blinks the UART might output some message.

At the moment, the result is as follows.
I bought another USB-TTL converter (CH340).
Setting up the minicom as in this instruction.
Yes, now some traffic is being transmitted.
But it is impossible to interpret it in any way.
This is how it looks like

My cheap CH340 based USB-TTL serial cable causes same issue.
The thread of is reporting this kind of issue.

In my case, FT232RL, PL2303TA based USB-TTL serial cable were stable.

Anyway, it seems that your Rock 3A is not dead but has a trouble, good luck!

These 2 USB-TTL Debug Cables, both FTDI chipset based, worked just fine on my Rock3A’s:

USB to TTL UART cables with CP210X, PL2303x and PL2303x gave me some trouble mostly because of baud rate limitation and possibly because some incompatibilities with it.

It’s very strange, because I was guided by the information that is presented on the official page specifically for the Rock3 model
It just says the opposite here. That all other chips, except CH340, are unstable.

But thanks to your clarification, I purchased a converter based on FT232.
This allowed me to connect successfully. Thanks.

I accessed the console via the serial interface.
As I see, the kernel is loading normally. No error messages occur.
There is still no video output to HDMI.

Here is the output from “dmesg”
dmesg -H -L -T -l crit,err
[Fri Feb 11 00:22:56 2022] arm-scmi firmware:scmi: Failed. SCMI protocol 22 not>
[Fri Feb 11 00:22:56 2022] arm-scmi firmware:scmi: Failed. SCMI protocol 19 not>
[Fri Feb 11 00:22:56 2022] arm-scmi firmware:scmi: Failed. SCMI protocol 17 not>
[Fri Feb 11 00:23:10 2022] rk_gmac-dwmac fe010000.ethernet: no regulator found

dmesg -H -L -T | grep HDMI
[Fri Feb 11 00:22:57 2022] dwhdmi-rockchip fe0a0000.hdmi: Detected HDMI TX controller v2.11a with HDCP (DWC HDMI 2.0 TX PH
[Fri Feb 11 00:22:57 2022] dwhdmi-rockchip fe0a0000.hdmi: registered DesignWare HDMI I2C bus driver

What else can be done?
Maybe I need to specify some specific kernel parameters in u-boot in order for HDMI to turn on?

My dmesg response are,
rock@rock-3a:~$ dmesg|grep HDMI
[ 0.700609] dwhdmi-rockchip fe0a0000.hdmi: Detected HDMI TX controller v2.11a with HDCP (DWC HDMI 2.0 TX PHY)
[ 0.701514] dwhdmi-rockchip fe0a0000.hdmi: registered DesignWare HDMI I2C bus driver

Exact same as yours, so the HDMI seems to be OK.
Please check the HDMI cable and the connector. The HDMI connector is tight. Push the connector strongly but don’t break it. A little more effort.
Good luck!

I tried two different cables on two different TVs. The result is the same - a black screen. At the same time, the message on the TV screen that there is no signal disappears. Just a black screen.

This is what my connection looks like.
I can’t push any further, I’m afraid to break it.

The following is indicated on the product description page.

As for HDMI, the maximum resolution is 4k@60Hz

Could it be that by default the HDMI output is set to a resolution and frequency incompatible with my TVs. My TVs have been produced for a long time, more than 3 years have already passed. Could that be the reason?

That’s too bad.
Is login or ssh connection ok? However, I have no other idea.

“3 years” is not so old. My TV is 7 years old and with 2K@60Hz but working with the Rock 3A.

Thanks for the help. I will ask a question in support. It may be a hardware malfunction.
I also noticed that I don’t have a jumper on my board to switch to MASKROM mode.
There is a place on the PCB for soldering, but there is no jumper itself.
Maybe I got a defective device.

What’s your TV Brand/model/resolution? Do you have another different HDMI cable you can try on?

The issue is resolved.
It was about the refresh rate of the screen. I added this to extlinux.conf
After the reboot, the image appeared on the screen.
Thank you all for your help.

Updated info
I reinstalled the system on a new SD card.
Made changes to the extlinux.conf file.
After the reboot, I didn’t see the expected result.

Last time I overlooked one more thing.
In addition to making changes to the extlinux.conf file,
I also completely disabled plymouth.
This step turned out to be the real solution.

At the same time, I still do not see the output of messages about loading the kernel,
although I removed “quiet” from the kernel parameters,
but at least an invitation appears to log in in to the console.
So far, that’s fine with me.

1 Like