Pi-Hole problems and setup

I was finally able to get Pi-Hole up on my two new Rock Pi S and thought I’d share. I have it running on ROCK Pi S D4W (512MB version with wireless) and a ROCK Pi S D2 (256MB vesion - yes I know it’s below spec for Pi Hole). Both are the V12 board versions. I got it working on Ubuntu and Debian images both dated 2020-03-16.

  • 1: Image memory card and boot board. I used SSH instead of adb was working well too, disconnects sometimes with the update.
  • 2: Change hostname/usernames/passwords
  • 3: Before trying Pi Hole install - “sudo apt-get install -y apt-utils dialog debconf dhcpcd5 git iproute2 whiptail cron curl dnsutils iputils-ping lsof netcat psmisc sudo unzip wget idn2 sqlite3 libcap2-bin dns-root-data resolvconf libcap2 lighttpd php-common php-cgi php-sqlite3”
    • Found it easier to install all the supporting programs I could find beforehand, seemed to work easier. Main ones install was failing on was dialog and then lighttpd, Once I loaded all of these it went easy.
  • 4: Run Pi Hole install - “sudo curl -sSL https://install.pi-hole.net | sudo bash”
    • Found you have to run as sudo bash. had better success with sudo curl.

Still getting back to it to measure performance. I installed on two different ones to have as my two DNS sinks on my network. Worked well in initial testing. Plan on ordering a 2nd one with 512MB long term.

Any other thoughts or suggestions?

With Armbian - which come with far better support OOB - you would not need to waste so much time.

  1. https://forum.radxa.com/t/armbian-for-rockpi-s
  2. armbian-config -> software -> softy -> Pi-hole
  3. Enjoy :slight_smile:

You can also try modern kernel experience without reinstalling.

Pi-hole project leader / owner also use Armbian on their machines:

Yes, thank you, I hadn’t tried armbian yet. Works fine in the armbian-config once you install it completely and everything that comes with it. But if you still want to manually install Pi Hole, it still crashes out without finishing without all of these dependencies installed.

I do like armbian though! Thanks a lot!

Well, then this problem is for Pi-Hole support forum.


i’m sorry but i’ve tried that, and there is no way to get it installed.
I start armbian-config, select pi-hole and hit install but install wizard exit and i go back to armbian-config.
I’ve tryied to install something else and it worked.
Is there anything special to do before installing pi-hole from armbian-config?


Hard to say if a problem is within armbian-config or pi-hole script that is called from it. Just use their official instructions:


ok, here is the problem :
[✗] Unsupported OS detected: Armbian 20.08.17 Buster

And the solution is provided just below :
If you are seeing this message on a fresh install, you can run:
‘curl -sSL https://install.pi-hole.net | PIHOLE_SKIP_OS_CHECK=true sudo -E bash’


1 Like

fixed for future builds. tnx