Penta SATA Kit Rock Pi 4 - OLED Config doesn't work

Hi, I just received my Penta SATA Kit for my Rock Pi 4 and installed it.
I run my rock pi with Ubuntu Server 18.04 (downloaded from the wiki). I managed to make the screen working with the command curl -sL | sudo -E bash - but it seems that I can’t change the configuration.
When I edit the file /etc/rockpi-penta.conf nothing change on the hardware. For example I changed the screen rotation and it didn’t changed on the screen.
I tried to restart multiple time the service (sudo systemctl restart rockpi-penta.service), restart the rock pi 4 and even updated it (sudo apt-get upgrade) but nothing change. Also, the button doesn’t work, when I press it nothing happens.
Can you help me ? I can give more informations about my hardware and software if needed.


I managed to make it work by renaming /etc/rockpi-penta.conf into /etc/rockpi-sata.conf, as in /usr/bin/rockpi-penta/, the program is looking at a config file named rockpi-sata.conf

However the button is still not working.

Hey, I’ll fix it now.

The button or the config file name ?

I think the button should work. Can you describe it in more detail?

When I press it nothing happen, no message nor screen changes. Maybe I can look to a log file ?
Also, I can’t find the code wich handle the button press, maybe I can add a print out to understand the situation

The code is located in

When I start the service manually I get two error messages :
Invalid GPIO pin specified
Invalid GPIO pin specified

cat /boot/hw_intfc.conf | grep pwm

I get

ls -al /sys/class/pwm

Did you reboot after installation?

Yes I rebooted multiple times
Result of ls command :
total 0
drwxr-xr-x 2 root root 0 Jun 9 11:20 .
drwxr-xr-x 74 root root 0 Jun 8 20:40 ..
lrwxrwxrwx 1 root root 0 Jun 9 11:20 pwmchip0 -> ../../devices/platform/ff420000.pwm/pwm/pwmchip0
lrwxrwxrwx 1 root root 0 Jun 9 09:36 pwmchip1 -> ../../devices/platform/ff420010.pwm/pwm/pwmchip1
lrwxrwxrwx 1 root root 0 Jun 9 11:20 pwmchip2 -> ../../devices/platform/ff420020.pwm/pwm/pwmchip2

dpkg --list | grep libmraa

ii libmraa 0.7 arm64 libmraa

Everything looks normal. Does the fan work?

Yes the fan works

Here is what I got in journalctl :
Jun 09 11:35:40 rockpi systemd[1]: Started Rockpi SATA Hat.
Jun 09 11:35:40 rockpi libmraa[1530]: libmraa version v2.1.0-1-geed896e initialised by user ‘root’ with EUID 0
Jun 09 11:35:40 rockpi libmraa[1530]: gpio: platform doesn’t support chardev, falling back to sysfs
Jun 09 11:35:40 rockpi libmraa[1530]: libmraa initialised for platform ‘ROCK Pi 4’ of type 20
Jun 09 11:35:40 rockpi libmraa[1530]: pwm_init: pwm0 already exported, continuing

I will provide a script to help you debug it tomorrow.

Ok thanks ! I will keep looking for solutions today :wink:

Have you find anything that can help me ?

Hi, any news @setq ? I tested on armbian and the button work, but with ubuntu the button deson’t work.