Penta hat on RPi 5 seems to have stoped working


I only just received my Penta hat yesterday and initially everything seemed to work fine

  • Drives showed when doing an “lsblk”
  • OMV showed drives as well

Now the next day I seem to be having issues

  • lsblk doesn’t show drives anymore
  • lspci shows:

00:00.0 PCI bridge: Broadcom Inc. and subsidiaries Device 2712 (rev 21)
01:00.0 Ethernet controller: Device 1de4:0001

Other than this:
The green led on the hat and the PI are showing
The pi seems to be behaving as expected (with the exception of it not seeing the hat)

things I tried:

  • replace the flex cable (just too be sure)
  • reseated the hat
  • reflashed PI OS

Is there any other logging I can generate to see what could be wrong?
(particularly in am keen to find out if the issue is on the Pi or the hat side)

Thanks a lot for any tips

Hi Ray71,

Do you have any other m.2 hats?

From the phenomenon you described, we can’t know whether Penta hat or Raspberry Pi 5 is broken.

Providing dmesg might help, but I’m not so sure.

how You power up everything?

This is what I get when looking at dmesg

nasberry@Nasberry : ~ $ dmesg | grep -i pcie

[ 0.000000] Kernel command line: reboot=w coherent_pool=1M 8250.nr_uarts=1 pci= pcie _bus_safe snd_bcm2835.enable_compat_alsa=0 snd_bcm2835.enable_hdmi=1 smsc95xx.macaddr=2C:CF:67:4B:67:F0 vc_mem.mem_base=0x3fc00000 vc_mem.mem_size=0x40000000 console=ttyAMA10,115200 console=tty1 root=PARTUUID=71c2cea3-02 rootfstype=ext4 rootwait cfg80211.ieee80211_regdom=NL
[ 1.671867] brcm- pcie 1000120000. pcie : host bridge /axi/ pcie @120000 ranges:
[ 1.678878] brcm- pcie 1000120000. pcie : No bus range found for /axi/ pcie @120000, using [bus 00-ff]
[ 1.687986] brcm- pcie 1000120000. pcie : MEM 0x1f00000000…0x1ffffffffb -> 0x0000000000
[ 1.696300] brcm- pcie 1000120000. pcie : MEM 0x1c00000000…0x1effffffff -> 0x0400000000
[ 1.704607] brcm- pcie 1000120000. pcie : IB MEM 0x1f00000000…0x1f003fffff -> 0x0000000000
[ 1.712910] brcm- pcie 1000120000. pcie : IB MEM 0x0000000000…0x0fffffffff -> 0x1000000000
[ 1.722389] brcm- pcie 1000120000. pcie : Forcing gen 2
[ 1.727606] brcm- pcie 1000120000. pcie : PCI host bridge to bus 0000:00
[ 1.889048] brcm- pcie 1000120000. pcie : link up, 5.0 GT/s PCIe x4 (!SSC)
[ 2.005546] pcie port 0000:00:00.0: enabling device (0000 -> 0002)
[ 2.011701] pcie port 0000:00:00.0: PME: Signaling with IRQ 38
[ 2.017530] pcie port 0000:00:00.0: AER: enabled with IRQ 38

other than this no errors or warnings

nasberry@Nasberry : ~ $ dmesg | grep -i error
nasberry@Nasberry : ~ $ dmesg | grep -i warning

the only peculiar thing I can make out of the login is that the bus still seems to be forced to gen 2


This does strike me as a little bit odd, as the config file should prompt it to go to gen=3.
There is a small thought in my mind that it may be a SW issue as I recently did a refresh (a 2nd one) but I am not 100% where I did that in sequence.

Good question:

I am using a new AC/DC adapter that should be able to provide 12V 5A directly to the Hat
(no separate power line to the PI)

Initially this worked but will measure it to be sure if it is really providing 12V

Still don’t fully understand why. but after another reseating of the flex cable and another refreshing of my SD cart the issue now seems resolved and stable. Thanks for chiming in everyone.

1 Like

Glad to hear it’s working.


Unfortunately it seems I celebrated too early. after a day of working correctly the unit again seems to be failing. It would seem there is some sort of electro mechanical issue. But it is difficult to say for sure and even after reseating the unit and flex cable I do not seem to be able to bring it back to life (the green light still switches on but other than that there seems to be no connection between the Pi and the Penta hat.

I am contacting Arace Tech to see how I can apply for a replacement :frowning:

In case any on has any other suggestions regarding diagnostics I could still do please feel free to let me know.


Can You test it on different pi5? Can You see any errors on logs?
Also You can try to use some ipa to clean flex cable, maybe there is something there?
That pcie connector was never that good idea :confused: Sonner or later I expected such complains.