Pachyderm on the rock pi


#1

Has Anyone Been able to Compile pachyderm?
After a few Minutes, my Pi Freeze up.
Any ideas?


#2

Which distribution you use? Ubuntu or Debian?


#3

Hi, I am using Ubuntu.


#4

Are you trying to build this?


#5

Yes that is what i am trying to do


#6

Okay, since i never worked with docker, i need to know, how exactly you trying to built it, since inside repo i don’t see anything arm related


#7

curl -O https://storage.googleapis.com/golang/go1.11.4.linux-armv6l.tar.gz
export PATH=$PATH:$GOPATH/bin
sudo go get github.com/pachyderm/pachyderm
cd $GOPATH/src/github.com/pachyderm/pachyderm
sudo make install
make launch
export ADDRESS=192.168.1.200:30650

sudo pachctl create-repo test
sudo pachctl list-repo


#8

I am not sure about the version of GO. Should i take for arm6 or 8

I tryed compiling it direcly on the Rockpi. I not sure how to cross compile it on my Ubunto Vertual box.


#9

About ARM, RockPi (and all boards i know) is ARMv8
And this https://blog.alexellis.io/go-comes-to-64bit-arm/ tells me that Go have specific armv8 x64 version there https://storage.googleapis.com/golang/go1.9beta1.linux-arm64.tar.gz


#10

I got my on https://golang.org/dl/
They have a version go1.11.5.linux-arm64.tar.gz i try the 2 of them to see.

let me try it now


#11

For those who want to install GO language

sudo apt remove golang
sudo apt-get autoremove
source .profile
curl -O https://storage.googleapis.com/golang/go1.11.5.linux-arm64.tar.gz
sudo tar -C /usr/local -xzf go1.11.5.linux-arm64.tar.gz
export PATH=$PATH:/usr/local/go/bin # put into ~/.profile


#12

It froze up again withthe version 11.5

Is There a way i can see the LOgs somewhere to understand why it Freezed up?

All i see it this:
rock@master:~$ go version
go version go1.11.5 linux/arm64
rock@master:~$ sudo go get github.com/pachyderm/pachyderm
rock@master:~$ cd $GOPATH/src/github.com/pachyderm/pachyderm
rock@master:~/go/src/github.com/pachyderm/pachyderm$ sudo make install

GOPATH/bin must be on your PATH to access these binaries:

GO15VENDOREXPERIMENT=1 go install -ldflags “-X github.com/pachyderm/pachyderm/src/server/vendor/github.com/pachyderm/pachyderm/src/client/version.AdditionalVersion=-82a7869060f00a48b266fffde9cdf87452740370” ./src/server/cmd/pachctl


#13

Are you trying to build it in console or you did unminimized system and install some desktop? Because with desktop at least it will be possible to tell what exactly go wrong


#14

I unminimized the system. I used the lxde desktop.
But when i compile i open a session in putty from my pc.
I compile from there. I added a & to compile in Background. It gave me a Stopped. No other message


#15

Is it possible for you to connect RockPi to any screen and try it like this?


#16

I think i found the problem. In the original Zip. There is 2 Garbage file.
rock@master:~/go/src/github.com/pachyderm/pachyderm$ ls
‘’$’\001\003\002\300\200\226\001\300\200’‘V’$’\001’‘h’$’\002\001’‘6’$’\001\v\002’’@’$’\203\226\001’’@’$’\203’‘V’$’\001’‘8’$’\004’
‘’$’\001\360\230’‘E@p’$’\002’’@8
I deleted them. And now i am able to compile without freezzing up the rockpi

Then i ran the : sudo make launch

rock@master:~$ cd $GOPATH/src/github.com/pachyderm/pachyderm
rock@master:~/go/src/github.com/pachyderm/pachyderm$ sudo make launch

GOPATH/bin must be on your PATH to access these binaries:

GO15VENDOREXPERIMENT=1 go install -ldflags “-X github.com/pachyderm/pachyderm/src/server/vendor/github.com/pachyderm/pachyderm/src/client/version.AdditionalVersion=-82a7869060f00a48b266fffde9cdf87452740370” ./src/server/cmd/pachctl
pachctl deploy local --dry-run | kubectl apply -f -
/bin/sh: 1: pachctl: Exec format error
error: no objects passed to apply
Makefile:357: recipe for target ‘launch’ failed
make: *** [launch] Error 1
rock@master:~/go/src/github.com/pachyderm/pachyderm$

when i try to run pachctl
-bash: /usr/local/bin/pachctl: cannot execute binary file: Exec format error

At this point, i am LOST.
I do not know what to do at this point. Why is pachctl not compile correctly?


#17

btw, If you adding code from console do this. Otherwise code will look a bit messy2019-01-27%2019_06_07-Pachyderm%20on%20the%20rock%20pi%20-%20Development%20and%20Programming%20-%20Radxa%20Forum%20-%20Tor%20Brows

As for
/bin/sh: 1: pachctl: Exec format error
that seems to be problem with arch. Maybe it’s trying to load armhf or something x86_64 because it fails to recognize that it’s on arm.


#18

I have open an issue on Git.

Cannot get to compile on the PI #3406

Hopefully, I have done it correctly.

Thankyou @dante4 for your Great Help. I will keep you inform if my Issue is accepted.


#19

Not like i helped you much (sorry about this). Hope this issue will get resolved soon!


#20

Hi
If someone ++ can go and comment that they would like an ARM version of Pachyderm. It would realy Help.