OTG & Gadget on Armbian 'current' branch?

Using the top left USB port as a gadget works with Armbian ‘legacy’ 4.4.y kernels. However, if I boot my Rock Pi 4 B+ into the Armbian ‘current’ 5.10.y kernel I can not use the same USB port in OTG mode. I have already attempted to use a patch in the Armbian build process to set dr_mode=“otg” on the appropriate USB device node in Device Tree, but it still doesn’t work.

I have read through a few other threads here which seem to be related, but are from 1-2 years ago. Does the mainline support for Rock Pi 4 include OTG or no?

https://docs.armbian.com/User-Guide_FAQ/#why-does-hardware-feature-xy-work-in-old-kernel-but-not-in-more-recent-one

I realize that is the case and do appreciate all that Armbian has already done to make my tasks simpler.

I am reaching out to the community with this post to see whether or not there have been other attempts and/or efforts to get the OTG port functional on a mainline kernel.

I suspected, based on my own attempts, that driver support and other necessary vendor BSP changes to the legacy 4.4.y kernel have not been ported to the mainline kernels. So, has the community tried to do so or are there plans in the works to do so?

I am asking because I am trying to build a solution using the Rock Pi 4 as a gadget and although it mostly works on the legacy 4.4.y kernel it is causing a number of kernel stack traces related to endpoint stalls. I don’t know what these mean and I am not enough of a Kernel/driver guy to resolve them. So, I decided to check out mainline to see if the same issues existed there, which led me to the current situation.

I am fine with using the legacy Kernel for OTG. However, I might need support to help understand and/or resolve the kernel stack traces I referred to before. Is there a good place for me to file a bug report regarding them?