OPNSense for Rock-Pi-E & Rock-Pi 4

Greetings to all!

I have successfully built OPNSense for Rock-Pi-E.
You can download here

ROCK-PI-E
OPNsense-21.1-OpenSSL-aarch64-ROCK-PI-E-20210513.img.xz

ROCK-PI-4C
OPNsense-21.1-OpenSSL-aarch64-ROCK-P-4C-20210513.img.xz

LAN - 1000Mbit port
WAN - 100Mbit port

Configuration via LAN

https://192.168.1.1/

Username: root
Password: opnsense

Please leave your feedback in this thread on the forum or on my website
https://personalbsd.org/wp-login.php?action=register

7 Likes

Amazing work by @SleepWalker

It worked on first boot omg things are coming together.

This is an updated version.
Now both the lan seem to work flawlessly.
Posting this over Opnsense firewall running on Rock-Pi-E, Great work by freebsd team and special thanks to @SleepWalker

Opnsense Lobby

Internet Speed test - This is my expected full speed.

Next is to test its limit with AV, IDS and VPN :wink:

Excellent, with the 4gb ram version more things could be done, it is a shame that it is not sold in the USA.

You don’t really be much of ram for opnsense or any other firewall.

2gb ram would be more than enough for firewall appliance use.

Does anyone know how to utilize wireless on this OPNSense?

Wireless communication does not work on board

Is there a way I can make it work ? Is this because RTL8821CU is not supported by FreeBSD ? I have a USB adapter with RTL8812AU which I can use in that case.

There is a way to make it work.
modify the rtwn (4) driver. man 4 rtwn.

It currently only supports RTL8821AU.

The driver for RLT8812AU is available and you can try to use it.
But I have not tested this option.

https://docs.netgate.com/pfsense/en/latest/wireless/hardware.html#status-of-802-11ac-support

My ROCK-PI-E has not been delivered yet.

1 Like

What is the default userpass for ssh?

Username: root
Password: opnsense

1 Like

Hi there,
when i try to to update via Webgui it always complains about a timeout, while executing opnsense-update respond “Fetching base-20.1.7-aarch64.txz: … failed, no signature found”. What am i doing wrong? EDIT: At least cli updater is working with updated image. Via WebGUI its still a timeout.

Also my umts-stick and my ubs ethernet-adapter won’t get recognized. When i plug them in they are not shown in the WebGui nor via lsusb.

Last but not least: is there an updated version of your image? EDIT: Found --> http://dev.kubsu.ru/images/OPNsense-20.7-OpenSSL-aarch64-ROCK-PI-E.img.xz

Thanks in advance,
NoDiskNoFun

Which chip is used and what is the driver name in freebsd for the chipset. Maybe @SleepWalker can enable it in the next build.

Yes there is newer version
I have hosted the same file on my serve and sometime dev.kubsu.ru server is slow depending on the region.
OPNsense-20.7-OpenSSL-aarch64-ROCK-PI-E-20201022.img.xz

Thats the strange thing. Lsusb and usbconfig only shows three USB hubs what ever i plug into the USB port. Ive also tested a keyboard and a sdcard reader with same result. Its always:

ugen3.1: at usbus3, cfg=0 md=HOST spd=FULL (12Mbps) pwr=SAVE (0mA)
ugen2.1: at usbus2, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=SAVE (0mA)
ugen1.1: at usbus1, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=SAVE (0mA)

Hi
It is very strange.
send me dmesg command result
deviceinfo -v

We got some logs incoming, Commander.

dmesg:

There is no deviceinfo (command not found) but devinfo. Hopefully thats right:

cd /boot/kernel
touch *
reboot

That did not do the trick. I’ve also tried to load/unload the usb module which gives me

kldload: can’t load usb: module already loaded or in kernel
and
kldunload: can’t find file usb

After some digging around i though it might be a hardware fault. So i booted up Debian. Here USB Devices are shown via lsusb and working just as expected. I’ve also tried three different opnsense images (even so i think http://dev.kubsu.ru/images/OPNsense-20.7-OpenSSL-aarch64-ROCK-PI-E.img.xz is the same as http://dev.kubsu.ru/images/OPNsense-20.7-OpenSSL-aarch64-ROCK-PI-E-20201022.img.xz) with same result, what brings me to the conclusion SleeperWalkers suggested commandset does not point the problem. Im also questioning myself how you get to this (@SleepWalker: thats a technical question, not a rhetorical), since ive red through dmesg and could not find any hint about missing or unable-to-load modules related to usb. Another though i got was that my Rock Pi E is a D8, without Wireless Communication, and so maybe it needs a different DTB (if something like this even exist in BSD), but thats just wild guessing. Another strange thing is that the three usb devices shown via usbconfig are usb1.1 and usb2 but the ports are usb3 and usb-c so there is also a missing usb3 hub. (if i am not totaly wrong here)

BTW, happy new year to you all =)

To fix something in the new OpnSense image.
You need to understand the reason why your USB does not work.
Try running FreeBSD on your Rock-Pi-E and testing your various USB devices in it.
You can connect the device and see how it is determined through the dmesg command, what drivers are loaded for kldstat to work.

And then draw conclusions

FreeBSD for Rock-Pi-E can be downloaded

OPNsense-21.1-OpenSSL-aarch64-ROCK-PI-E-20210513.img.xz

Good luck.