Openvpn install

It’s possible to install openvpn in rock3a? I’m trying to install it but no success.

it shows this error:

Sat Oct 2 07:28:22 2021 ERROR: Cannot open TUN/TAP dev /dev/net/tun: No such file or directory (errno=2)

tried to fix it with some tutorials, but fails everytime.

I have found the supplied kernel to be very limited, unfortunately.
Take a look here on how to build a new kernel, etc.

this is my step to install openvpn, can you show your step image

I did the openvpn install normally, but when I launch with some .opvn file it shows the message that i posted. I tried some commands looking in some forums but none of them worked.

I use the following steps to do it and success:
1.you should release the testing sourse on /etc/apt/sources.list.d/apt-radxa-com.list
image
2.run sudo apt update
image
3.run sudo apt-get install -y linux-4.19-rock-3-latest


4.run sudo reboot
image
5.run uname -r,and you can see it 's 4.19.193.11-rockchip*
image
6.into the borad and run sudo modprobe tun
image
7.then you can see /dev/net/tun
image

nice, it worked. Openvpn is working.

I did the upgrade and is now this newer one 4.19.193.11-rockchip, but I got some docker problem now. I’m going to create another post for this.

Thanks for the help :slight_smile: