NVMe Detected but timesout making FS


#1

Hello,
I have an Asgard 256GB NVMe drive attached and recognized. I am able to partition and begin to format the drive then it fails with:

nvme 0000:01:00.0: Timeout I/O 832 QID 1

This repeats until the system crashes. Has anyone else experienced this with this or other NVMe drives?

I have used the drive in a USB enclosure with a Mac and was able to write much to the drive. I did however notice over time the writing to disk had some problems. The write rate dropped off and the drive was quite warm. Not sure if that is normal thermal throttling or a problem.

I will try the enclosure connected to the RockPi on USB3 and see what happens but obviously I’d prefer to use it connected to the NVMe port.


#2

The drive worked fine attached via USB. I should say that max transfer rate was only about 34MB/sec where as on a Mac, same nvme and enclosure, transfers were between 130-1000MB/sec.
Formatting ext4 over USB worked.
Then put the NVMe back into the rockpi4b adapter. Drive mounted OK and transfer rates were around 300-400MB/sec.
Tried formatting the drive again, this time with ext2, same timeout error occured when:

 Writing inode tables: 1033/1908

I tried formatting with fat and got the same timeout.

I also installed rockpi4-dtbo and uncommented “intfc:dtoverlay=pcie-gen2”

From reading other posts it seems drives either are detected and work or not detected. Odd then a formatted disk does not seem to have issues, izone works, dd as well to write 10GB of data.


#3

I can confirm that we met similar issue on ROCK Pi 4 and also PC running 16.04. I believe this issue is related with the firmware of the NVMe controller and also bug in the Linux kernel. It happens at formatting but not dd. You can attach the nvme to usb enclosure and run on ROCK Pi and check if formatting works.


#4

Formatting does indeed work when connected via USB.

The problem does not appear with other NVMes then?


#5

I’ve decided against using this NVM (Asgard 256GB), it seems to throttle writing and read speeds quite quickly. Looking at either the Samsung said to work or perhaps a Crucial brand one.
Will there be a concise list at some point of what has been tested and/or “officially” works with…


#6

https://wiki.radxa.com/Rockpi4/FAQs#What_M.2_SSD_are_supported.3F

- Known working -

  • Samsung EVO series( M key, NVMe ), work well on ROCK Pi 4, fast speed
  • KingSpec NVMe M.2 2280( M key, NVMe ), works well
  • MaxMemory NVMe M.2 128G( B&M key, NVMe ), works well

- Known not working -

  • HP EX900( B&M Key, NVMe ), detection failed on ROCK Pi 4, works with PC.

#7

Updated wiki with a summary.

Thanks.


#8

Thanks for the contribution to the wiki :slight_smile: