Nothing to do. With Windows it is absolutely unstable

Nothing to do. With Windows it is absolutely unstable. I have installed Windows 10 and a management application that I use remotely. It disconnects constantly. . I had to throw it in a drawer and buy a mini pc. I don’t even know if it is a problem with the card, it is only 3 months old, and the parent company can replace it. On Aliexpress they pretend nothing has happened. SOME THIEVES

Hm, if you used provided image - it shouldn’t be like this. If you tried to use your own image…well, that’s baaad.

As far as my tests go - there is problem with some versions of Intel drivers (seems like they kinda forgot to fix atom video drivers). And that’s totally on Intel side, since linux is working just fine

Also, heat is another potential issue with Windows. Do you use heatsink?

1 Like

I put a fan and the temperature is around 40-45 degrees. I also thought it was a temperature problem, but it is like it freezes. I find it with the Windows screen, in the desktop, but it is practically dead. And it needs to be restarted

Hm, if it’s freeze, then it’s different problem. Do you use wifi or rj45 for network?

What power supply do you use? Does it support QC or PD?

Power supply is a QC

I suspect it’s a driver issue. Can you test our latest 21H1 image with all drivers preinstalled?

https://dl.radxa.com/rockpix/images/win10_21h1_en/Install.WIM

Installation guide:

https://wiki.radxa.com/RockpiX/install/Windows.wim

Thanks. But is it not possible to have only the drivers to update?
I have a management program that in case of reinstallation of the know I would have to install myself again …

Hm, something not right, I’m getting “The image file may be invalid” when i try to install it. SHA1: E35098338AA67BA3B66215C878578B03C00B759B

update #1:

Was able to install Radxa’s image by using windows installer, no idea what happened

1 Like

I tried the latest 21H1 image and also have tons of BSODs, the only solution in to disable intel hd graphics. also on my own installation of win10. after installing the intel hd graphics drivers, it goes down quickly. does some flickering and then down.

exactly like this guy mention in this article. he found a very weird workaround but not a proper fix.

https://hothardware.com/reviews/rock-pi-x-digital-mini-aquarium-project