Not booting Rock Pi X

My first post. Just got the board. I had to buy a 9v QC charger. When I plug in the charger the blue LED comes on and it gets bright(QC switching to 9v??). If I wait the green and white radxa X logo flashes for an instant and goes to an EFI Shell prompt.
I tried the Shell map in the wiki and got 3 pci devices." ls" failed on all with no dir.

You need to install an Operating System, usually either Windows or Linux. See the bottom of this page: https://wiki.radxa.com/RockpiX/getting_started

More info. I had the Ubuntu iso on a stick plugged into a USB port. I held the del key. I didn’t get the BIOS screen.

I typed some text and edited the text with arrow keys and the delete key. The delete key is actually a backspace. I switched to keyboard with separate del and backspace and I got to the boot screen. :grinning: The boot override only lists the RFI shell. I will try other USB ports. I’m using the blue USB 3 port. More later.

I actually am having similar issues and am curious to see what comes of your testing. I am not seeing my ISO image as a boot option in USB3 or 2 ports

I finally got it to work. I made a USB startup disk on my Ubuntu PC. I used the app called “Startup Disk Creator”. Writing the ISO with a “dd” command didn’t work. I suspect I needed to partition the USB stick before doing the “dd”. “Startup Disk Creator” may handle the partitioning, but this is only a guess.
https://ubuntu.com/tutorials/create-a-usb-stick-on-ubuntu#1-overview

I am very happy, now. I will wait for the Pi X heatsink to do more stressful apps. It’s on preorder waiting for parts.

I have the same problem with Rock Pi X… I cannot install any system either Win or any other system. I follow all the same procedures as any of my other pc’s or Pi’s to no avail. The bios shows the drive I want to boot from but just goes to the Radxa screen whenI choose it. I am powering the unit with my variable power supply to specification but still no joy. The responses I got about this problem seem to tell me I am too dumb to flash the system properly after 30 years of working with pc’s! Maybe I am having a Biden moment?

All systems must use UEFI to boot. Additionally, the boot partition (I believe) needs to be Fat32. This comes with the limitation that you can’t simply flash the Windows 10 iso to a USB (Fat32 has a file size limit of 4GB, install.wim is bigger).

To install Windows, one should use Rufus to create a bootable USB.

1 Like

When I boot, the Radxa screen stays on for a very long time before the Ubuntu screen appears. You may need to wait longer.

Do you mean that a USB stick created with Microsoft Media Creation Tool can’t be used? I tried this with Windows 10 20H2 but couldn’t boot.

Step 1. Download rufus
Step 2. Download image
Step 3. Use Rufus to burn image into usb
Step ???.
Step N. Profit

I was thinking the same thing. I have a Rock Pi that did the same thing to my amazement. I waited on the X for several hours but nothing happened.

Hmm. I don’t have a Windows PC (the Rock Pi X was supposed to fill this gap) so I can’t use Rufus. Tried all the suggestions using Ubuntu. No Luck. If I come up with a fix I’ll report back.

Managed to get unetbootin to produce a USB disk that was recognised by the BIOS. Unfortunately it failed to produce a valid copy of install.wim. It’s also got quite a few bugs. The following command line got it going but I guess I may have formatted the drive wrong as install.wim is the one that’s too big for fat32.

sudo QT_X11_NO_MITSHM=1 /usr/bin/unetbootin installtype=USB targetdrive=/dev/sdc1

I’ll keep trying

Reformatted to NTFS. Windows now installing.

I will try that. I used Rufus for the Win10 iso on a drive formatted NTFS but it did not work with the Pi-X. I will try again with Unetbootin. (never heard of it)

This worked for me: RockpiX/install/Windows.wim - Radxa Wiki