Not able to install new OS

Im a newbie at linux, especially arm based.
Ive purchased the 4B to create a nas with dns (instead of static ip).
I tried (using etcher on linux mint) to install a different OS than the one i pre-purchased it with
(in my case Linaro) on a different sd card. But the system won’t load.
What am i doing wrong?
Something i did noticed is that the sd that came with has 4 partitions and etcher only creates two.
I tried ubuntu/debian dietpi but nothing else loads but the provided sd.

Much appreceated.

You are using SD cards, correct?

Do you get any output over the HDMI when booting from any of the images?

Have you tried Armbian? That works fairly well with Rock Pi 4.

Also, do you have a USB -> TTL device you can connect to the RockPi? Most of the images are set to output boot info over that, that happens before the OS boots: Serial Console

Yes I am using sd cards.
No output except with the original sd.
Unfortunately, I am not familiar with ttl devices.(what is that?)
Is armbian based on debian?


Will try tomorrow. Thanks IgorP

Hey RemdA,

I’m just curious… where’d you buy the pre-installed linaro sd card?

When I contacted the technical support, they also said they don’t provide one.
But then when I mentioned this link, they said “Allnet is our distributor”.
I bought a bundle with the m.2 expansion, heatsink etc…

Hey guys.
I am sad to announce that neither of the armbians were successful.
Spent 3 hours burning different sd cards with different OS’s but nothing.
How can it be that only the Linaro loads up?

Can you reproduce to load the Debian image? Which images have you tried? Are you using the same sdcard from Allnet?

I think it might be the issue of the other sd card. If you want to challenge, you can download images from:

and write to the sd card from Allnet with ecther.

Armbian test images that you don’t need to waste time. Just follow