Not able to format (using mkfs.ext4 ) m2 nvme SSD attached with Rock pi 4b


System config: Rock Pi 4b
eMMC (16gb): Debian 9

sshing into the Rock pi running headless.

Issue: Not able to format M2 NVMe SSD 1TB
Actual Result: Rock Pi, wifi stopped working and a blue or green light start flashing from the top side of rock pi
Expected Result: Writing superblocks and fielsystem accounting information: Done and Rock Pi should remain responsive.

In order to use the SSD for storage, I wants to partition, format and mount (auto) it. I’m able to partition it using sudo fdisk /dev/nvme0n1 command. However, when I move forward to format this partition using sudo mkfs.ext4 /dev/nvme0n1p1, then after 2 minutes while on “Writing superblocks and fielsystem accounting information” step, Rock Pi seems crashed and never complete this step.


  • ssh connection auto terminates.
  • I’m not able to reconnect to Rock Pi, until I reboot Rock Pi.
  • Rock pi showing offline (on router connected devices settings).
  • I’m also noticing that Rock Pi, wifi stopped working and a blue or green light start flashing from the top side of rock pi, every time I try to format nvme0n1p1 partition. (I tried 3 times)

I really appreciate, if someone can provide a solution to format ACER M2 NVMe SSD 1TB for Rock Pi and mount it.

What power adapter are you using? The SSD actually eat a lot of power, peak current up to 3A somethings, that’s 10W.

@jack I’m using below mentioned power adapter supplied with Rock Pi 4b.

Power Supply Adapter QC 3.0
Input: AC110-240V 50/60Hz 0.3A
Output: DC5V=2.6A / 9V=1.7A / 12V=1.3A

Product Description: Power Supply Adapter QC 3.0

Hi @jack,

Thanks for replying. As I mentioned in another post of mine what power adapter, I’m using with Rock Pi4b. Apart from that power adapter, I have another Power adapter for my phone with following specs. Qualcomm Quick Charge 3.0 (QC3.0): 18 Watt USB-A output: 5V/3A, 9V/2A, 12V/1.5A)

Do you think, I should change Power adapter and again try to format the partition on m2. nvme SSD (1 tb)?

Last night, I left Rock Pi running after running the sudo mkfs.ext4 /dev/nvme0n1p1 command for almost 5 hours (Even after ssh connection dropped & blue/green light start flashing the top of Rock Pi.) in a hope that flashing is still working and once its complete, the light stopped blinking, however, it didn’t happened and I had to reboot rock pi.

Moreover, can someone give me an Idea, how much time it normally takes mkfs.ext4 to complete formatting 1tb m2. nvme SSD?

@jack I tried to format m2. nvme SSD again. This time instead of connecting over wifi, I choose ethernet in hope that this will work. However, this even didn’t work.

I captured some error logs to share, if someone can suggest something useful out of it.
01- Screenshot of running the format command.

02- Screenshot of dmesg | tail when server crashed & communication lost.

03- Cpu activity

Based on your suggestion, I connected my rock Pi with 18w adapter and try to format m2 nvme SSD by running mkfs.ext4 command. Same thing happen and

Received below dmesg just before system hangs:

Every 2.0s: dmesg | tail -20 linaro-alip: Tue Jun 9 23:49:36 2020
[ 710.319740] nvme 0000:01:00.0: Timeout I/O 1003 QID 6
[ 710.320201] nvme 0000:01:00.0: Timeout I/O 1004 QID 6
[ 710.320661] nvme 0000:01:00.0: Timeout I/O 1005 QID 6
[ 710.321122] nvme 0000:01:00.0: Timeout I/O 1006 QID 6
[ 710.321582] nvme 0000:01:00.0: Timeout I/O 1007 QID 6
[ 710.322044] nvme 0000:01:00.0: Timeout I/O 1008 QID 6

So on the wireless turning off if you are connecting over that you’ll need change the default setting for power save to 2 from 3 which is the default.
$ sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
Contents of file should like this before changes

wifi.powersave = 3

Edit wifi.powersave = 3 to wifi.powersave = 2
save file

$ sudo shutdown -h --reboot now
Note: if you are also connected via ethernet you can do ifdown and ifup on the wireless connection