No Worky, Solid Green LED only

Brand new Zero (D4E32-T) with eMMC and first power up, Green LED is on solid, but does not boot as the HDMI has no output, and USB comms port is not doing anything either.
Bad out of the box? I hope not, I have big plans for this board.

Hi, what system do you use?

Radxa Zero (D4E32-T)

I think he meant what operating system?

To recap, I just purchased the Radxa Zero D4E32-T and based on the website, the default operating system is android. All I have done so far is to connect to my monitor, add power and add keyboard. I get a green light immediately and nothing else. there is no data on HDMI port or USB Comms. Dedicated power supply 2.5A

TY, I have updated the response. Operating system is Android by default or so I’ve been told. Either way, it doesn’t appear to power up at all.

Did you install the system yourself? Why do you say Android is the default?

Just to be clear, the LED is always permanently green independent from the system it is running.

I would try to see if the eMMC is accessible with the official guide. The eMMC should be accessed as mass storage and you should see some Android files.
Next I would look for the output from the UART console if there is any hint.
But I think the easiest would be to erase the eMMC and reflash Android.

Another hint would be that the HDMI cable is not compatible. HDMI has different versions that could be rejected by the device.

From >>> https//wiki_radxa_com/Zero/getting_started

It says as a beginner to start board for the first time, it recommends to boot from eMMC if available.
Below is where I got the Idea that the eMMC already had an OS.
Under (Choose Your Storage Option), The Startup Guide reads: “If you want to install another OS to eMMC, you will first need to [erase the eMMC]”

Also there are several youtube video’s from last year promoting the Radxa Zero where they boot up for the first time while on camera, and Android 9 was pre-installed.
But I will try to install an OS via Micro SD, using Radxa Download page.


Starting the board for the first time

Radxa Zero can boot from either eMMC or microSD Card. >>> However, for beginner it’s best to stick with your board’s default storage, i.e. use eMMC when it is present, and microSD when eMMC is not available. This avoids the need to update U-Boot configuration to boot your chosen device, which can be challenging for the beginner.

Choose your storage option

  • Flash image to eMMC

If you want to install another OS to eMMC, you will first need to [erase the eMMC] then you can install any supported Linux distros from our [download] page. You can also follow this guide to [reinstall Android to eMMC]

  • Flash image to microSD card

I have Flashed Android 9 from the Radxa Zero downloads page, again i get no activity. Is it possible that I can send this board back for testing or repair?

I have now flashed the SD card and I still get nothing. I dont believe it works because using the PC to check if the usb (comms port) is even active yields nothing. not sure what to do except to mail back and see if testing or repair is possible.

Thank you for your advise. I have tried everything at this point. the HDMI is working on another Pi board, i dont think thats my issue. The USB comms in never awake per PC testing. I appreciate your time.

I found the problem, it was the operator. A simple misinterpretation led me down a rabbit hole.
I had a great learning experience, But its late, so I will share tomorrow.
v/r

I’m also facing the same issue for my brand new Zero (512 MB - No eMMC model)
Using micro SD flashed with Armbian (tried DietPi also but same issue)
Green LED is on solid. No HDMI output (even my monitor detect the connection)
UART console also not working.
Any help please

Able to get UART output in a Linux box (Windows not supporting PL2303 anymore)
It seems Radxa Zero is looping into auto-reboot.