No WIFI in Debian

I tried to install Debian to be able to use with OMV, but I can’t get the WIFI to work.I assume the usual drivers work perfectly on the latest version of Ubuntu.I copied the files to the / usr / lib / firmware folder both by myself, that creating the folder brcm, but on reboot it does not go. Am I wrong?

what’s the output of

sudo dmesg | grep brcm

sudo] password for max:
[ 13.316364] bluetooth hci0: firmware: failed to load brcm/BCM4345C0.hcd (-2)
[ 13.316370] bluetooth hci0: Direct firmware load for brcm/BCM4345C0.hcd failed with error -2
[ 13.316376] Bluetooth: hci0: BCM: Patch brcm/BCM4345C0.hcd not found
[ 15.620162] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[ 15.620325] usbcore: registered new interface driver brcmfmac
[ 15.620423] brcmfmac mmc1:0001:1: firmware: failed to load brcm/brcmfmac43455-sdio.bin (-2)
[ 15.620427] brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.bin failed with error -2
[ 16.634284] brcmfmac: brcmf_sdio_htclk: HT Avail timeout (1000000): clkctl 0x50

Error -2 means ‘file not found’.
The correct folder to place the files: /usr/lib/firmware/brcm

image
It doesn’t work

The path should be

/lib/firmware/brcm/

The destination is the usual. With / usr or directly in libs it is the usual folder. The problem was the name. I had to rename the file to brcmfmac43455-sdio.bin. Now it works